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1 – INTRODUÇÃO 
 
O software do PROTEUS VSM é uma ferramenta ideal para os estudantes e 
profissionais que desejam desenvolvimento de aplicações analógicas e digitais. Ele 
permite desenvolvimento completo de projetos através esquemáticos, simulações e 
layout’s (PCB). 
 
O objetivo desta apostila é apresentar as funções básicas para a utilização do 
software PROTEUS. A apostila foi desenvolvida com uma linguagem simples e 
abordando as funções mais utilizadas no desenvolvimento de um projeto eletrônico 
desde seu esquemático até a criação do layout. Com o intuito de torná-la mais 
objetiva e também material de consulta, muitas funções estão somente indicadas, 
as explicações específicas podem ser observadas selecionando a função e 
teclando F1, ou através do help do software. 
 
Não temos o objetivo de ensinar ou demonstrar os conceitos de circuitos elétricos 
ou eletrônicos, já que este conhecimento assim como o do sistema operacional 
Windows e seus pacotes básicos, são considerados pré-requisitos para a utilização 
do PROTEUS. 
 
 

1.1 - Conceitos Básicos 
 
 
O grande diferencial do PROTEUS com relação a outros softwares é a capacidade 
de simular circuitos elétricos e circuitos microcontrolados, pois além de fornecer 
componentes animados, também possui as ferramentas necessárias para depurar o 
software·desenvolvido para o microcontrolador, acompanhando seu comportamento 
na simulação do hardware. 
 
No PROTEUS, quatro módulos trabalham em conjunto fornecendo todas as 
ferramentas necessárias para o processo de desenvolvimento, veja abaixo quais são 
eles: 
 
 

� ISIS – Inteligent Schematic Input System (Sistema de entrada de esquemático 
inteligente) 
 

Ferramenta para desenvolvimento de esquemáticos, sendo possível gerar projetos multi-sheet, 
gerarem relatórios, entre outras funcionalidades relativas a desenvolvimento de esquemáticos. 

 
 
� VSM – Virtual System Modeling (Modulação de Sistema Virtual) 
 

 Este módulo é responsável pelas simulações e animações de componentes e, principalmente, na 
utilização de microcontroladores, já que é através desta tecnologia que é possível emular 
microcontroladores no PROTEUS.  O VSM trabalha em conjunto com o ISIS, permitindo que 
diretamente no esquemático sejam utilizados componentes animados, como motores, led’s, display’s, 
etc. 
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� PRO-SPICE – SPICE3F5 para simulação matemática 

 
O PRO-SPICE também trabalha em conjunto com o ISIS, utilizando modelos matemáticos SPICE, 
permitindo que na simulação sejam utilizados instrumentos e gráficos. 

 
 
� ARES – Advanced Routing and Editing Software (Roteamento Avançado e Edição de 
software) 

 
O desenvolvimento de layout’s (PCB) é realizado no ARES, onde através de uma interface própria, 
podemos importar o netlist do ISIS, definir padrão de trilhas, pad’s, vias, etc. O ARES permite 
desenvolver projetos de um até 16 layers, roteamento automático, auto-placement, etc. 

 
 
Apesar de termos quatro módulos trabalhando no PROTEUS, efetivamente têm dois 
ambientes de trabalho, sendo o ISIS responsável pelo esquemático, simulação e 
animação de componentes e o ARES ferramenta para o desenvolvimento do layout. 
 
 

1.2 – Atualizações Automáticas 

 
 
Essa versão atual do PROTEUS pode atualizar-se automaticamente se assim for 
configurado. O Update Manager notificará o usuário automaticamente quando uma 
nova versão do software for lançada. Por padrão o Proteus checará a existência de 
novas versões assim que o software for ativado, mas a freqüência dessa checagem 
pode ser configurada através do menu: 
 
System > Update Manager, como é representado na janela de Update do 
PROTEUS na figura 1. 
 
 
 
 
 
 
 
 
 
 

 
 
 

 
Figura 1: Janela Update Manager para atualização do Proteus 
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2 – AMBIENTE GRÁFICO 
 
Como informado, para desenvolvimento de esquemáticos utilizaremos o ISIS, 
portanto, agora serão apresentado mais detalhadamente as ferramentas, interface 
gráfica e demais funções disponíveis no ISIS.  

2.1 – Interface Gráfica 
 
 
O ISIS possui uma interface gráfica simples e intuitiva, a figura 2 destaca algumas 
“áreas” específicas. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figura 2: Ambiente de operação gráfica ISIS. 
  

2.1.2 – Vista Panorâmica 
 
Por padrão, esta janela localiza-se ao lado esquerdo da janela do ISIS, porém 
para movê-la, somente para o lado direito da janela, basta clicar na coluna vertical 
que separa a janela de edição e arrastá-la até o outro lado, lembrando que o seletor 
de objetos permanecerá junto dela. 
 
 
A vista panorâmica, geralmente, mostra uma visão geral de todo o desenho que está 
na janela de edição, porém também possui outras funções: 

Coordinate Display 

Janela de Edição 

Vista Panorâmica 

Seletor de Objetos 

Run Simulation / Animation 

Goto Sheet 
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� A borda azul representa a borda da folha, já o retângulo verde representa a área que está 
sendo visualizada na janela de edição. Clicando com o botão esquerdo em qualquer 
ponto da vista panorâmica, o retângulo verde será centralizado de acordo com este ponto, 
e a janela de edição terá seus elementos “redesenhados”, para manter concordância com 
esta movimentação, o que equivale a realizar um pan na janela de edição. 

 
� A vista panorâmica também é utilizada para visualizar elementos que estão selecionados, 

no seletor de objetos.  

2.2 – Grid 

 
O grid pode ser visualizado na janela de edição, para habilitá-lo ou desabilitá-lo 
acesse o menu: 
 
View > Grid, como mostra a figura 3, ou simplesmente tecle G. 
 
 
 
 
 
 
 
 
 
 
 

Figura 3: Acesso ao Grid. 
 
Na opção View > Snap **th, pode-se escolher entre as opções 10, 50, 100 e 500 th, 
onde th representa milésimo de polegada ou mils.  
 
 
2.3 – Units - Unidades 
 
A precisão de trabalho no ISIS é de 10 nm, simplesmente para manter 
consistência com o ARES, porém a unidade de trabalho do ISIS é o th , milésimo de 
polegada ou mils, sendo restrita somente a esta unidade.  

2.4 – Coordinate System – Sistema de coordenandas 

 
O sistema de coordenadas é relativo à unidade de trabalho, e é possível visualizar 
qualquer ponto que o cursor esteja localizado, no canto inferior direito da janela. 
 
A origem do sistema de coordenadas é localizada no centro da janela de edição, 
indicada por um “target” azul. Podemos alterar a origem utilizando o que chamamos 
de false origin, onde simplesmente indicamos um ponto na janela onde será esta 
nova origem e teclamos a letra O. 
 
Este novo ponto será a nova origem para o desenho, e para indicar que estamos 
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utilizando uma “false origin” às coordenadas são mostradas em magenta. Para 
desabilitar esta função e voltar a utilizar a origem padrão basta clicarmos no 
comando View > Origin ou pela barra de ferramentas Display Commands no ícone.. 

2.5 – Navegação 

 
Essa versão do Proteus concentra sua navegação através dos sheets pelo botão 
central do mouse. Rolando o botão central para frente ou para trás com o cursor 
sobre a janela de edição, podemos notar que o zoom se aproximará e afastará. 
 
Ao pressionar o botão central é perceptível o Track-Pan, modo no qual “agarra-se” ao 
sheet no ponto em que ocorreu o clique. Quando se movimenta o mouse é possível 
visualizar a folha inteira. Para deixar o Track-Pan, basta pressionar novamente o 
botão central. 
 
Com a tecla F8 é possível centralizar a folha não importando o nível de zoom ou a 
localização que você esteja. 

2.6 – Barras de Ferramentas 

 
As barras de ferramentas do ISIS estão distribuídas ao longo do topo e lateral 
esquerda da janela, estas são as posições padrão. É possível alocá-las nas bordas 
da janela, basta clicar e arrastá-la para a posição desejada. 
 
Para habilitar ou desabilitar a visualização das barras de ferramentas disponíveis 
clique sobre o menu:   
 
View  > Toolbars...  
 
onde aparecerá a janela Show/Hide Toolbars, representada pela figura 4. 
 
 
 
 
 
 
 
 
 
 
 

 
Figura 4: Janela Show/Hide Toolbars. 

 
 
 

Segue abaixo as barras de ferramentas disponíveis no ISIS: 
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.File / Print  
 
.Display Commands  

 
.Editing  Command  
 
.Design Tools 
  
.Main Modes  
 
.Gadgets  

 
.2D Graphics  
 
.Orientation Toolbar  
 
 
 

3.	CRIANDO ESQUEMÁTICOS 
 
 
O ISIS trabalha alguns tipos de arquivos sendo os mais importantes: 
 

� .DSN – Arquivo contendo os esquemáticos. 
� .DBK – Arquivo de Backup. 
� .SEC – Arquivo section contendo esquemáticos exportados. 
� .MOD – Arquivo que contém as informações de projetos hierárquicos, subcircuitos, etc. 
� .LIB – Arquivo de Bibliotecas. 
� .SDF – Arquivo contendo os Netlists. 

 
Somente é possível trabalhar com um arquivo, por janela, no ISIS. 
 

3.1- Iniciando um Novo Design 

 
Há dois procedimentos para criar um novo projeto: 
 

1. Clicando no comando New Design (From Default Template), comando da 
barra, figura 5, que iniciará um novo projeto utilizando o mesmo padrão 
(template) do projeto já aberto. 

 
 

 
 

Figura 5: Barra de ferramenta ícone New Design selecionado. 
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2. Utilizando o comando File > New Design, iremos acessar a janela Create 

New Design, como i lust rado  na  f igu ra  6 ,  onde temos os templates 
disponíveis no ISIS. 

3.  
 

 
 
 
 
 
 
 
 
 
 
 
Figura 6: Janela Create a New Design, para seleção do template desejado. 

 
 
No caso da janela, representada pela figura 3, deve-se selecionar o template 
desejado e clicar OK, para iniciar um novo Design utilizando as configurações do 
template selecionado. 
 

3.2 – Configurando um Template 

 
O template é um arquivo .DTF, onde gravamos todas as configurações de aparência 
do esquemático (estilos de texto, estilos de gráficos, cores dos componentes, etc.), 
sendo que as configurações de aparência do template são acessadas pelo menu 
pull down Template, veja a figura 7. 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 7: Menu de configuração Tamplate. 

 
 
No menu Template é possível acessar as seguintes opções:  
 

� Goto Master Sheet - Em um projeto Multi-Sheet, acessa a Root Sheet 1 ou Master sheet, 
já que esta possui as configurações, que são utilizadas por todas as outras sheets. 
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� Set Design Defaults – Configura as opções padrões  para  cores  do  plano  de  fundo,  grid,  

seleção  de  objetos, animações, etc. como também configura qual é fonte padrão a ser 
utilizada pelo ISIS. 

 
� Set Graph Colours – Ajusta as cores que serão utilizadas nos gráficos, incluindo as cores dos 

sinais analógicos e digitais. 
 
� Set Graphics Styles – Este ítem permite configurar quais as opções dos estilos (espessura  

de  linha,  cor, preenchimento)  que  os  elementos  irão  utilizar  ao  serem  inseridos  na  
área  de  edição,  lembrando  que necessariamente todos os elementos de um 
esquemático possuem um estilo associado, automaticamente ou não, dependendo do tipo 
de elemento. É possível criar novos estilos clicando-se no botão new da janela Edit Global 

Graphic Style. 
 
� Set Text Styles – Da mesma forma que o item anterior, permite alterar as configurações 

de todos os estilos de texto existente no ISIS, podendo-se também criar novos estilos. Os 
estilos de textos são associados a todos os textos que aparecem no esquemático, alguns 
exemplos de estilos são Component ID, Component Value, Properties, Wire Label, etc. 

 
� Set Graphics Text – Permite configurar todas as características dos textos que são inseridos 

somente pelo comando 2D Graphics Text. 
 
� Set Junction Dots – Configura a aparência e tamanho dos junctions dots que serão inseridos 

no esquemático. 
 

� Load Styles from Design –  Copia  as  configurações  dos  itens  acima,  para  o  ambiente  
atual  a  partir  de  um arquivo design (DSN). 

 
Todas as configurações do template são salvas no próprio arquivo, ou seja, cada 
arquivo possui sua própria configuração de sheet e aparência, lembrando que 
também é possível configurar tamanho da folha, borda da página e outras 
configurações. 

 3.3 – Editando as propriedades do Sheet 

 
É possível alterar o tamanho da folha utilizada no projeto, para isto, acesse o menu: 
System>Set  Sheet  Size..., abrirá a janela representada pela figura 8, que 
possibilitará   selecionar os tamanhos padronizados de A0 até A4, além de um 
tamanho personalizado. Os tamanhos da folhas devem ser inseridos em polegadas, 
já que esta é a unidade padrão do ISIS. 
 
 
 
 
 
 
 
 

Figura 8: Janela de configuração do Sheet Size Configuration. 
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Acessando o menu Design>Edit Sheet Properties, acessamos a janela (figura 5) 
onde podemos inserir o nome título e nome da folha. Esta opção é importante 
quando utilizamos uma borda com um cabeçalho, já que é possível no ISIS criar 
cabeçalhos seja preenchido automaticamente com os dados, preenchidos nos 
campos do menu Design. 
 

3.4 – Criando um cabeçalho (Header Block) 
 
Procedimento para criação de um cabeçalho: 
 

1. Seleciona-se o Master Sheet  pelo menu: 
• Template  >Go  to  Master  Sheet... 
 

2. Utiliza-se as ferramentas 2D Graphics Text Mode  (linhas,  retângulos,  etc.)  
c l icando sobre o ícone A, como mostra a f igura 9 ,  local izado á  
esquerda do ambiente ISIS.   

 
 
 
 
 
 
 
 
 

 
 

Figura 9: Ícone 2D Graphics Text Mode. 
 
3. Abr irá a  jane la do graphic style no seletor de objetos. Clique sobre 

TEMPLATE, como mostra figura 10. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figura 10: Ferramenta Template para inclusão de cabeçalho, graphic style. 
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4.  A partir deste ponto podemos criar a borda e o cabeçalho da folha de 

acordo com o padrão desejado. 
 

� Clique no ícone 2D Graphic Design Mode, localizado no canto inferior a 
esquerda, conforme figura 11. 

 
 
 
 
 
 
 
 
 
 

 
Figura 11: Ícone 2D Graphics Line Mode. 

 
� Crie o cabeçalho com os espaços e informações que lhe convém. 
� Clique dentro de um das caixas criadas, neste momento abrirá-se uma 

janela, figura 12, para que sejam inseridas as informações desejadas. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 12: Janela de inserção e configuração de informações do cabeçalho. 
  
 
String – Inserir a informação por escrito. 
Justification – Configura posicionamento do conteúdo da string. 

Font Attributes – Configura a formatação da letra, como fonte, tamanho (em polegadas), etc. 
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OBS:  Para mover, deletar, rotacionar um objeto, basta clicar com o botão direito sobre 

o mesmo e selecionar a opção de interesse, veja figura 13. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 13: Janela de configuração do objeto. 
 

5. Pode-se inserir uma imagem no cabeçalho, logo da empresa, por exemplo, 
pelo menu: File > Import Bitmap..., como é apresentado na f igura 14 ,  
e inserir os textos que podem ser automaticamente atualizados, de acordo 
com as propriedades inseridas no menu: Design > Edit Properties... 

Figura 14: Conclusão do cabeçalho. 
 
Para que esta funcionalidade esteja ativa devemos inserir textos de acordo com a 
tabela 1. 
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@DTITLE Título de Design de acordo com o menu Design > Edit design Properties 

@STITLE Título de Sheet de acordo com o menu Design > Edit sheet Properties 

@DOCNO Número de Design de acordo com o menu Design > Edit design Properties 

@REV Número da Revisão de acordo com o menu Design > Edit design Properties 

@AUTHOR Nome do Autor de acordo com o menu Design > Edit design Properties 

@CDATE Data de criação do desenho – Formato fixo e dado não alterável 

@MDATE Data de modificação do desenho – Formato fixo e não alterável 

@WL CDATE Data de criação do desenho de acordo com o padrão Windows, “long date format”. 

@WS MDATE Data de modificação do desenho de acordo com o padrão Windows, “short date format”. 

@CTIME Hora de criação do desenho de acordo com o padrão Windows, “time format”. 

@MTIME Hora de última modificação no desenho de acordo com o padrão Windows, “time format”.  

@PAGENUM Número corrente da página das folhas no projeto. 

@PAGECOUNT Número total de folhas do projeto. 

@PAGE Número da página na folha do projeto padrão – n da pág./n. total de folhas. 

@FILENAME Nome do arquivo .DSN 

@PATHNAME Nome do arquivo .DSN e todo caminho das pastas, onde se encontra o arquivo. 

 
 

3.5 – Configuração do Ambiente de Trabalho 

 
As configurações contidas no menu System, vejam representação na figura 15, 
alteram o ambiente de trabalho para todos os arquivos que forem abertos, as opções 
Set Animation e Set Simulation Options, são específicas para cada arquivo. 
 

 
 
 
 
 
 
 
 
 
 
 
 

 
 

Figura 15: Menu System e suas opções. 
 
 
 
Portanto, no menu System é possível configurar os seguintes no ambiente de 
trabalho: 
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� Set BOM Scripts – Janela que configura como será gerada a lista de materiais, seguindo 

um dos 3 padrões existentes, ou outro padrão que pode ser criado de acordo com a sua 
necessidade. 

 
 
� Set Enviroment – Permite alterar as opções de AutoSave Time, Número de Undos 

disponíveis, Sincronização de anotações (Back annotate) com o ARES, restauração do 
estado ultimo estado do projeto, ou seja ao abrir-se o projeto novamente, o zoom e o 
ultimo sheet aberto será carregado, este item também altera as opções de Grid e 
Cursores. 

 
� Set Paths – Pode-se alterar qual o caminho o ISIS irá buscar as bibliotecas, templates e 

modelos de simulação. Neste item há a opção setar que ao buscar projetos a pasta padrão 
será a última pasta utilizada. 

 
� Set Property Definitions – Esta opção permite alterar e criar as propriedades que são 

utilizadas nos Devices, possibilitando alterar suas descrições, tipo, nome e como serão 
visualizadas. 

 
� Set Text Editor – Altera o padrão de fonte que é utilizado pelo estilo Default font. 
 
� Set Key Board Mapping – Neste item pode-se criar, editar atribuições de teclas aos 

comandos do ISIS. 
 
 
Como visto anteriormente é possível alterar as opções de cores do ISIS, pelo menu: 
Template > Set Graphic Colours... 
 
 

3.6 – Salvando um Template 

 
Após fazer as configurações dos menus Template e System, deve-se salvar o 
template.  O mesmo poderá ser salvo em qualquer pasta, porém se for adicionado 
arquivos através do comando: New Design... será visualizado apenas os templates 
que estiverem na pasta declarada no menu: System > Set Paths > Template 
Folder, o qual abrirá a janela de configuração representada pela figura 16. 
 
O arquivo template deverá ser adicionado em Template folders clicando sobre o 
ícone  . Neste momento abrirá uma janela para seleção do diretório do arquivo 
gerado e salvo anteriormente. Para salvar o arquivo template utiliza-se o comando 
File > Save Design As Template..., que salvará o arquivo com a extensão .DTF . 
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Figura 16: Janela de configuração do Path. 
 
 
 

3.7 – Inserindo Objetos 

 
Após a criação do template e configurar o ambiente de trabalho podemos iniciar 
um novo esquemático, e inserir objetos na área de edição. O ISIS possui duas 
bibliotecas de símbolos e mais de 25 bibliotecas de dispositivos, incluindo modelos 
animados para simulação. 
 
Os objetos serão inseridos a partir de uma biblioteca, seu acesso dar-se-á clicando 
sobre o ícone Components  , em seguida, clique no botão P do seletor de 
objetos, ou simplesmente pressione P no teclado, abrira a janela da figura 17 com os 
diversos componentes inclusos na biblioteca do ISIS. 
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Figura 17: Janela Pick devices para inserção de objetos e componentes. 
 

 
Na figura 17 podemos observar os campos Category, Sub-Category e 
Manufacturer, onde podemos selecionar componentes (de mercado) escolhendo o 
tipo de elemento (Category - CIs analógicos, Capacitores, resistores, etc), após isso 
na Sub-Category podemos selecionar a família do componente e por fim, 
selecionar o fabricante. 
  
Observe que no canto inferior direito, visualiza-se qual símbolo PCB este 
componente está associado, lembrando que este símbolo é da biblioteca do ARES.  
 
Os componentes selecionados podem ser selecionados seguindo os passos acima 
ou digitando o nome ou Part number do componente no campo Keyword. Ao 
encontrar o componente desejado, com um duplo clique sobre o mesmo, o 
componente aparecerá no seletor de objetos, siga o mesmo procedimento para 
inserir os demais componentes necessários. 
 
Depois de selecionados todos os componentes, feche a janela Pick Devices, e 
comece a inserir os dispositivos na área de edição. Na figura 18 tem-se um exemplo 
de inserção de objetos na área de edição, neste caso trata-se do componente 
AND_2 selecionado no seletor de objetos.  Na vista panorâmica é visualizado o 
componente que será inserido, e como o mesmo será inserido. Utilizando os comandos 
de da barra Orientation defini-se em que orientação o componente será inserido. 
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Figura 18: Exemplo de inserção de objetos. 

 

3.8 – Exemplo de circuito 
 
 
Será apresentado neste momento um exemplo de circuito para familiarização com o 
software. Primeiramente selecione os componentes que serão utilizados neste projeto na 
biblioteca, segue abaixo os mesmos:  

� AND_2;  
� RESISTOR;  
� LED-RED;  
� LED-GREEN 

 
Veja a ilustração da figura 19. Estes componentes estão nas bibliotecas Modeling 
Primitives e Optoelectronics.  
 
Insira também: 
 

� 1Gerador de Clock Digital (DCLOCK), clicando sobre o ícone Generators.    
� 2 Alimentação (POWER) 
� 1 GND (GROUND), acessamos na barra de ferramenta o ícone inter-sheet Terminal  . 

 
 

 
 

Figura 19: Componentes selecionados da biblioteca. 

 
OBS:  Para adicionar o componente ao ambiente ISIS deve-se clicar sobre o nome do 

mesmo na área de seletor de objetos, a imagem dele aparecerá na vista panorâmica. 
Leve o cursor do mouse até a janela de Edição e dê um duplo clique no local 
desejado para montagem do circuito. 
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3.9 – Editando as Propriedades de um Objeto 

Após inserir os objetos, se rão  editadas suas propriedades gráficas (cores, 
preenchimento, etc.) e elétricas, valores de componentes, tolerâncias, etc. 
 
As alterações das propriedades dos objetos deverão ser feitas clicando, uma vez, 
com o botão direito do mouse sobre o objeto e uma vez com o botão esquerdo do 
mouse no mesmo objeto, ou ainda, pode-se clicar no componente e pressionar 
Ctrl+E. 
 
A janela Edit Component se abrirá, figura 20, sendo que para cada tipo de 
elemento, esta janela terá opções diferentes. No caso, por exemplo, do resistor, 
configure seu valor para 100 ohms, siga o mesmo procedimento para alterar a 
freqüência do gerador para 1 Hz. 
 
 

 
 
 
 
 
 
 
 
 

 
 

Figura 20: Janela Edit Component de configuração de componentes. 
 
O valor do componente também poderá ser alterado utilizando o menu: Instant  Edit 
Mode, para acessá-lo clique com o botão direito do mouse, somente no valor do 
componente. Por exemplo, ao clicar no valor do resistor, aparecerá a janela 
representada pela figura 21. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 21: Janela Edit Component Value de configuração do valor do componente. 
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Este procedimento também será utilizado para editar qualquer outra propriedade que 
o componente tenha, e esteja sendo visualizada na área de edição. 

3.10 – Movimentando e Interligando Componentes 

 
Os comandos barra Editing Command  possibilita respectivamente, 
copiar, deletar, movimentar e rotacionar os componentes inseridos no esquemático 
de uma única vez sem que suas posições sejam alteradas. 
 
O movimento de um único componente por vez, também é possível, para fazê-
lo, deve-se selecionar e arrastar o componente para o local desejado, lembrando 
que se o mesmo estiver conectado aos wires, o caminho do wire será refeito 
automaticamente para manter este componente conectado ao circuito. 
 
Utilizando as ferramentas mencionadas pode-se posicionar e interligar os 
componentes do exemplo conforme figura 22. 
 
 

 
 

Figura 22: Circuito exemplo utilizando os componentes selecionados anteriormente. 
 
 
Os componentes são conectados através da conexão wire. Para conectá-los deve-se 
aproximar o cursor do mouse ao ponto de conexão, este cursor se tornará um lápis 
verde. Clique com o mouse no ponto de conexão, comece então a criar o wire 
para conexão, perceba que ao realizar este processo não é necessário acessar 
outro comando. 
 
O ISIS possui uma facilidade chamada Wire Auto Router (WAR), onde ao 
conectar um componente ao outro é verificado qual a melhor opção (ou menor 
caminho), para o “wire” realizar. Caso o caminho realizado pelo “wire” não seja o 
mais adequado para o seu projeto, ao iniciar a inserção do wire, clique com o botão 
esquerdo do mouse, nos pontos onde o wire deverá passar e finalize-o clicando 
sobre o ponto de conexão do outro componente. 
 
Não é permitido criar wires sem conexão. Um wire necessariamente deve estar 
conectado a dois pinos no mínimo. 
 
A função chamada wire repeat, permite conectar a um barramento ou fio diversos 
pinos, bastando conectar o primeiro e cada pino seguinte, com um duplo clique, a 
conexão será feita automaticamente, veja exemplo na figura 23. 
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Figura 23: Conexão de pinos em um barramento. 

 

4. SIMULAÇÃO DE CIRCUITOS 
 
 
O VSM do PROTEUS é responsável pela simulação e animação de circuitos e 
componentes, utilizando componentes animados e instrumentos. Será apresentado 
agora o funcionamento desta ferramenta acoplada ao ISIS, utilizando o mesmo 
circuito do Exercício 01, deve-se iniciar a simulação, clicando sobre o botão “Play”, 
localizado no canto inferior esquerdo da janela, conforme figura 24. 
 
 
 

Figura 24: Ícones Run Simulation / Animation, localizado no canto inferior 
à esquerda da tela do ISIS Porfessional. 

 
 
Ao iniciar a simulação, observa-se o aparecimento de alguns pontos vermelhos e 
azuis, e os fios com cores diferentes, como apresenta a figura 25. 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 

Figura 25: Alteração de cores dos fios do circuito montado quando simulado. 
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Os pontos significam os estados lógicos, que por padrão ficam: 
 

� Vermelho = “1”  
� Azul = “0” 
� Os cabos indicam o sentido da corrente através das setas e a polaridade através das 

cores. 
 
Estas opções são configuráveis nos menus: 
Template > Set Design Defaults e System > Set Animations Options 
 
No menu Set Animations Options, pode-se configurar também a velocidade da 
animação, setando quantos quadros  por  segundo  e  quanto  tempo  avançará  para  
cada  quadro.  O importante neste item é manter uma proporção entre as opções 
Frames per Second e Time Step per Frame, ou seja, a relação abaixo deve ser 
mantida para que a simulação seja a mais real possível. 
 
Frames per Second = 20, portanto o Time Step per Frame deve ser 1segundo/20 = 50 ms. 
 
OBS:  Geralmente, não é necessário alterar o parâmetro default, somente em animações 

mais específicas. 
 

4.1 – Utilização de Instrumentos 
 
As simulações e utilização de instrumentos no Proteus são gerenciadas pelo módulo 
VSM, que oferece instrumentos de medição como: Osciloscópio, voltímetro, 
amperímetro, analisador lógico e mais oito instrumentos. Todos podem ser 
acessados pelo ícone  . 
 
Cada equipamento possui uma particularidade, assim como um instrumento real.  Por 
exemplo, montaremos o circuito da figura 25, selecionando na biblioteca os 
elementos Battery, Fuse, Lamp., Pot-Hg, Resistor e Switch. 
 
 
 
 

 
 
 
 
 
 
 

Figura 25: Circuito exemplo de instrumentos. 
 
Os instrumentos de medição de tensão e corrente podem ser adicionados clicando 
sobre o ícone Virtual instrument modes, veja figura 26. 
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Figura 26: Ícone Virtual instrument modes. 
 
Selecione os instrumentos: DC Voltmeter (voltímetro corrente contínua) e DC 
Ametter (amperímetro de corrente contínua). 
 
Ao iniciar a simulação, observa-se os níveis de tensão e de corrente deste 
circuito, nele será utilizado um fusível animado.  Quando o valor do potenciômetro for 
alterado, o fusível se “romperá”. 
 
A utilização de instrumentos no Proteus é bastante intuitiva, já que todos se 
assemelham com instrumentos reais, inclusive em seus parâmetros de trabalho, por 
exemplo, em um voltímetro é possível alterar o valor da resistência interna, 
possibilitando medições mais próximas do real. 
 

4.2 – Análise gráfica 

 
Além da análise interativa no Proteus, é possível realizar análises gráficas dos 
circuitos, para estudo das respostas de determinados componentes, o que em uma 
simulação interativa muitas vezes não é possível. Através módulo PROSPICE, 
pode-se realizar 13 análises gráficas, por exemplo, análise analógica, digital, 
freqüência, Fourier, distorção, etc. Estas análises envolvem sete estágios 
relacionados baixo: 
 

� Projetar o circuito a ser analisado. 
� Inserir os geradores de sinal  nos pontos requeridos. 
� Inserir os Probes, de tensão  ou corrente , nos pontos a serem analisados. 
� Inserir o gráfico de acordo com a analise desejada clicando no ícone  
� Inserir os Traces no gráfico, utilizando o menu Graph > Add Trace...  
� Configurar os parâmetros da simulação tempo, freqüência, etc. 
� Executar a “simulação”, utilizando o comando Graph > Simulate Graph...  

 
Ao executar os passos acima, tem-se o resultado da análise plotada no(s) gráfico(s) 
de acordo como configurado. 
 
No exemplo da figura 27, é utilizado um transformador, do tipo TRANS-2P2S, 
com indutâncias de 10H no primário e 2,5H no secundário. Na entrada do 
transformador há um gerador senoidal, SINE, com 80 V de amplitude e 60 Hz. Será 
realizada uma análise analógica, comparando-se os sinais de entrada e saída no 
mesmo gráfico, com um tempo de 0 a 100 milisegundos, Para iserir o instrumento 
de análise o Analogue Analysis clique sobre o ícone Graphic Modes, 
conforme figura 27. Este instrumento possui ícones e menus facilitando a análise, 
onde podemos realizar um zoom, verificar níveis de tensão no nosso caso, em um 
determinado instante e verificar a diferença de tempo entre dois pontos, sendo um  
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primeiro clique no gráfico o ponto do primeiro cursor e Crtl+ outro clique o segundo 
cursor. 
 
 
 
 
 
 
 

 
 

Figura 27: Ícone Graphic Modes. 
 
 
O resultado pode ser observado na figura 28.  
 
 
 
 
 
 
 
 
 
 

Figura 28: Simulação do circuito transformador, gerador de sinal senoidal e o gráfico. 
 
Clicando com o botão direito do mouse sobre a janela de Analogue 
Analysis  abrirá o menu representado pela figura 29. Selecione o menu: 
Maximize (Show Window). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 29: Menu de configuração da janela Analogue Analysis, Maximaze (Show Window). 
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Uma janela de apresentação dos gráficos irá se abrir, Analogue Analysis - Prospice 
conforme figura 30.  Os menus que aparecem nesta janela possuem as opções 
encontradas nos menus Graph, View, Options e Help, contendo somente as opções 
utilizadas nos gráficos.  No menu File também encontramos as opções para imprimir 
e exportar o gráfico. Para efetuar configurações de cores da janela, clique sobre o 
menu: Options > Set Graphic Colours. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 30: Janela Analogue Analysis – Prospice. 
 
 

4.3 – Simulação de Circuitos Microcontrolados 

 
O Proteus VSM possui bibliotecas com os microcontroladores das famílias 68K, 
8051, ARM7, AVR, Basic Stamp, HC11, PIC10, 12, 16 e 18, sendo a política da 
Labcenter (desenvolvedora do Proteus), utilizar sempre componentes do mercado e 
conforme a necessidade ou solicitação são criadas novas bibliotecas com modelos 
de microcontroladores.  Lembrando que todos os componentes destas bibliotecas 
possuem modelos de simulação e somente com uma licença completa do Proteus 
teremos acesso a todas as bibliotecas. 
 
Nas simulações é possível depurar passo a passo o código carregado no 
microcontrolador, utilizando as ferramentas de debug do Proteus, ou executar a 
simulação, e depurando em conjunto com outras ferramentas como, MicroChip 
MPLAB 6, IAR Embedded Workbench, Keil uVision 3, CodeVision AVR, entre 
outros ambientes de desenvolvimento que podem ser consultados no site da 
Labcenter – www.labcenter.com 
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Todos os modelos de microcontroladores estão habilitados a executar os arquivos 
binários .BIN ou hexadecimal .HEX, que são arquivos somente com código numérico 
e são gerados por qualquer compilador, também  é  possível  trabalhar  com  outros  
formatos  que  possuem  informação  de  depuração  (variáveis, constantes,  etc.)  
como: ELF/DWARF,  COFF,  UBROF,  OMF51,  COD,  BAS,  SDI,  etc.,  que  
depende  do compilador que utilizamos. 
A simulação com microcontroladores possui um componente fundamental que é o 
Source Code Control System, que tem duas funções básicas: 
 

� Registrar o código fonte no ISIS, o que permite a execução, edição e o debug do código 
sem a necessidade de mudar para outro aplicativo para alterar o código. 

 
� Definir as regras de compilação do código fonte, para gerar o código objeto. 

 
Como comentado anteriormente, podemos utilizar outros compiladores para realizar 
estas funções. 
Acesse o menu abaixo para definirmos o compilador que utilizaremos, bem como suas 
configurações. 
 
Source > Define Code Generation Tool,, aparecerá a janela como mostra a figura 
31. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 31: Janela Code Generation Tools. 
 
 
Na figura 31, no campo Code Generation Tool, no item Tool, deve-se escolher 
qual o compilador será utilizado entre as opções: Assembler ASEM 51, ASM11, 
AVRASM, AVRASM32, MPASM e MPASMWIN. 
 
No campo Make Rules, é  possíve l  especificar a extensão do código fonte e 
código objeto e também definir uma linha de comando onde, geralmente, especifica-
se qual arquivo (código fonte ou código objeto) o compilador carregará. 
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4.4 – Exemplos de Simulação com Microcontroladores 

 
Neste exemplo será utilizado o compilador MPASM e acessando as propriedades do 
PIC em Program file será definido o arquivo do código objeto, que no caso, é o 
Display2x16.DSN. Para abri-lo, clique sobre o ícone abrir ou acesse: File > Open 
design.... 
 
.... \PIC16\Exercicio2\ Display2x16.DSN 
 
Abrirá o circuito conforme figura 32. 

Figura 33: Arquivo exemplo Display2x16.DSN. 
 
O menu Source permite fazer as configurações para compilação, antes de iniciarmos 
a simulação é necessário conhecer este menu onde encontra-se as seguintes 
opções: 
 

� Add Add/Remove source file... – opção que altera o caminho e o arquivo fonte do projeto. 
� Define Code Generation tool... – Adiciona uma nova ferramenta para compilação. 
� Setup External Text Editor - Opção para setar outra interface IDE para edição do código 
� Build All – Compila o código que foi alterado e verifica se há erros, utilizado o compilador 

definido no item. 

� Define code Generation tool. 
 
É possível acessar o código fonte para editá-lo clicando no nome do arquivo que 
aparece abaixo do item Build All. 
 
O arquivo deverá ser compilado, a fim de gerar o .HEX, para execução do projeto. 
Para fazê-lo clique sobre o menu: Source > Add/Remove source file... Abrirá a 
janela representada pela figura 34. 
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Figura 34: Janela Add/Remove source file. 
 
Na qual será solicitado o microcontrolador, na caixa Target Processor e o código, 
na caixa Code Generation Tool, sendo neste caso o U1–PIC16F84A e MPASM, 
respectivamente. 
Para carregar o código acesse o menu: Source  e clique sobre o nome do arquivo. 
Abrirá a janela Source Editor representada pela figura 35, na qual deverá selecionar 
o arquivo de extensão .txt , clicando sobre o ícone abrir pasta, abra-o e salve-o com 
extensão .asm.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 35: Janela Source Editor. 

 
Agora é possível compilar gerar o arquivo .HEX, através da compilação do arquivo. 
Após salvar o programa com extensão .asm, feche a janela representada pela figura 
35, e acesse o menu: Source > Build All... Neste momento, se todos os 
procedimentos anteriores estiverem corretos, aparecerá uma janela de compilação,  
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Build log conforme figura 36. Caso contrário verifique a informação de erro. 
 
 
 
 
 
 
 
 

 
Figura 36: Janela Build Log. 

 
OBS: O arquivo .HEX gerado será linkado ao microcontrolador. Para confirmar a existência 

do .HEX no microcontrolador, selecione-o com o botão direito do mouse e clique 
sobre o menu Edit Properties... Abrirá a janela, Edit Component, representada pela 
figura 37. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 37: Janela Edit Component. 
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Ao clicar no ícone “Run simulation” , iniciaremos a execução do programa e 
verificaremos o funcionamento do circuito, porém não é possível com este tipo de 
simulação acompanhar a execução do código. 
 
Deve-se iniciar uma simulação passo a passo para o acompanhamento da execução 
do programa através do menu: Debug> Start/Restart Debugging ou pelo botão 

. Para visualizar as janelas de debug do microcontrolador acesse o menu: 
Debug e selecione as opções que encontram-se abaixo de Simulation Log . Então 
abrirão as janelas de monitoração que variam de acordo com o microcontrolador, em 
nosso exemplo apresentam as ilustradas na figura 38: 
 

� PIC CPU Source Code – Código do programa em execução no microcontrolador. 
� PIC CPU Program Memory – Acesso aos  endereços  de  m em ór ia .  
� PIC CPU EEPROM Memory – Memória EEPROM 
� PIC CPU Data Memory – Memória de dados 
� PIC CPU Registers – Registradores 
� PIC CPU Stack 

 

Figura 38: Janela PIC CPU Source Code – U1 para monitoramento do microcontrolador. 
 
 
No menu Debug e na janela Source Code temos comandos que permitem a 
execução o código passo a passo, inserir break points, executar partes específicas 
do código, como segue abaixo: 
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� Run Simulation - Executa o código sem interrupções. 
 
 

� Step Over Subroutine – Executa a toda a sub-rotina, em que o cursor estiver 
localizado, parando a execução na linha subseqüente. Neste caso, é como se a sub-
rotina fosse uma linha de execução do código. 
 

� Step Into Subroutine – Executa passo a passo a sub-rotina, em que o cursor estiver 
localizado . 
 

� Step Out the Subroutine – Executa e sai da sub-rotina, que estiver sendo executada 
passo a passo. 
 

� Execute until cursor position – Executa o código até onde estiver localizado o cursor. 
 

� Insert Break Point – Insere ou retira Break points no código. 
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5. FUNCIONALIDADES ADICIONAIS 

5.1 – Design Explorer 

 
O Proteus conta com uma poderosa ferramenta para navegação e exame do 
esquemático através do Design Explorer. Trata-se de uma ferramenta extremamente 
complexa e versátil. Para demonstrá-la vamos abrir o arquivo Isistut.dsn que está 
localizado no seguinte diretório: 
 
C:\Arquivos de programas\Labcenter Electronics\Proteus 7 Professional\SAMPLES\Tutorials 
 
Acesse o menu: Design > Design Explorer, então aparecerá a janela chamada 
Physical Partlist View, a qual apresentará uma lista de todos os componentes 
usados nessa folha, veja figura 39. 
 

Figura 39: Lista dos componentes utilizados no esquemático. 
 
 
 
 
 
 
 
 
 
 
 
Através do ícone Find , é possível localizar rapidamente um componente, ou 
mesmo uma ligação ou um sheet. 
 
O Design Explorer também pode ser utilizado para checar a conectividade. Por 
exemplo, com um duplo-clique sobre componente U1 na coluna da direita. Observa-
se uma lista de todas as ligações dos pinos do componente aparecerá do lado direito 

Note: 
� Neste exemplo é de apenas uma folha, mas se estivéssemos trabalhando num projeto multi-

sheet observaríamos todos os elementos de todas as folhas componentes do projeto. 
� O componente SW1 não tem nenhum package associado a ele (veja o texto “missing” em 

vermelho) e isso caracterizaria um problema quando procedêssemos ao ARES.  
� Observar pequenos possíveis erros como esse leva apenas alguns segundos, mas numa larga 

escala isso pode significar grande economia de tempo. 
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e todos os componentes presentes no sheet no lado 
esquerdo. Note que ao clicarmos com o botão direito na ligação U1 (PIC16F84A), por 
exemplo, e selecionar a opção: Goto Schematic Net tem-se um excelente método 
de visualização para verificar as conexões. 

5.2 – Cross Probing 

 
O Cross-probing é uma técnica interessante para analisar e checar tanto o seu 
esquemático quanto o layout PCB simultaneamente. Essa função permite selecionar 
um componente no esquemático e observá-lo através de footprint na placa de circuito 
impresso. Como exemplo, será utilizado o mesmo arquivo Display2x16.DSN.  
 
Atenção! Para que o próximo procedimento seja efetuado corretamente, é 
necessário que o arquivo esteja aberto tanto no ISIS como no ARES, para isto, clique 
sobre o ícone do ARES no ISIS. Certifique-se que ambos os arquivos contenham o 
mesmo nome e preferencialmente, deixem dispostos os componentes e que os 
mesmos estejam roteados. 
 
No ISIS, acesse o menu: Design Explorer e selecione Physical Partlist View 
(clicando no ícone ). Na lista da direita é perceptível os vários componentes. 
Clique com o botão direito sobre um deles e escolha a opção: Goto PCB Part. Se o 
procedimento foi seguido corretamente o ARES destacará o componente escolhido. 
 
Utilize procedimento semelhante para destacar as ligações entre componentes. Para 
tanto, Selecione o menu: Physical Netlist View (através do ícone ). Será visível 
uma lista à direita com todas as ligações. Clicando com o botão direito na ligação 
desejada e escolhendo a opção: Goto PCB Net o ARES destacará a ligação.  
 
Veja na figura 40 o resultado do cross probing deste exemplo no ambiente ARES. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 40: Resultado do cross probing, layout do circuito elétrico. 
 



 

 36

 PROTEUS 

ANACOM ELETRÔNICA LTDA 
Fone/Fax: (11) 3422-4200 

 www.anacom.com.br 
 

 

5.3 – Criação de Símbolos 

 

O símbolo no ISIS é a junção de diversos elementos gráficos, que não possuem 
características elétricas e são gravados na biblioteca Symbols. 
 
Podemos acessar a biblioteca Symbols, clicando no ícone  , da barra de 
ferramentas e clicar no botão P, do seletor de objetos, veja exemplo na figura 41. 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 

Figura 41: Biblioteca de símbolos. 
 
 
Os símbolos contidos na biblioteca SYSTEM, são protegidos contra alterações e 
caso seja necessário alterar algum símbolo, deve-se inseri-lo, alterá-lo  e salvá-lo na  
biblioteca  USERSYM  por padrão ou em qualquer outra biblioteca que tenha sido 
criada. 
 
 
Procedimento para criação de uma biblioteca de símbolos 
 

1. Clique sobre o ícone  2D Graphic Symbol Mode e pressione botão L no seletor de 
objetos. Abrirá a janela Symbols Library Manager, figura 42. 

 
2. Selecione a opção Create Library, veja o indicativo na figura 42. 
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Figura 42: Janela Symbol Librareis Manager. 
 

 
3. Insira o nome da biblioteca em Nome do arquivo que será criada, conforme figura 43, e  

 

 

 

 

 
 
 
 
  
  
 
 
 
 
 
 
  
   
 
    Figura 43:  Janela Create New Library 
 
4. clique em OK. 

 
 
 
 
 
 



 

 38

 PROTEUS 

ANACOM ELETRÔNICA LTDA 
Fone/Fax: (11) 3422-4200 

 www.anacom.com.br 
 

 
5. Definir a pasta em que será localizada a biblioteca, lembrando que deve ser um caminho que 

esteja configurado no item System> Set Paths...>Library Folders. 
 

6. Definir quantidade máxima de itens que a biblioteca terá, que pode variar entre 1 e 4096. 
 

7. Para adicionar bibliotecas existentes, na janela Symbols Libraries Manager, selecione-as, 
em seguida clique em Copy Items, veja ilustração na figura 44. 
 
 

 
A janela Symbols Libraries Manager, possibilita, mover e renomear itens de uma 
biblioteca, que não estejam protegidas.   
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figura 44: Janela Symbols Libraries Manager. 

 

 
8. Abrirá uma janela de confirmação do transporte dos componentes, clique em YES em 

seguida, close para finalizar o processo. 
 

9. Clique sobre o ícone 2D Graphic Line Mode, criação do símbolo sem preenchimento ou no 

ícone 2D Graphic Closed Path Mode, símbolo com preenchimento e selecione a opção 

Component no seletor de objetos, conforme figura 45. 
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Figura 45: Seleção da opção component no seletor de objetos. 
 

10. Esboce o componente com o cursor do mouse. Para desenhar formas arredondadas, 
pressione a tecla CTRL e mova o cursor do mouse. Feche os pontos do desenho. Como 
exemplo, será feito um amplificador operacional, como mostra a figura 46. 

 
 

 
 
 
 

Figura 46: Símbolo exemplo, amplificador operacional. 
 

11. Clique no ícone pin  (à esquerda) para inserção de pinos. Selecione a opção default. 
 
12. Posicione os pinos em seus devidos lugares. 

OBS: Atente para que os pontos de conexão estejam para fora. 
 

13. Insira a origem no símbolo. Selecione o ícone Symbol mode  em seguida, clique em P não 
seletor de objetos, abrirá a janela Pick Symbols, conforme figura 47. Selecione nas caixas de 
diálogo: 
 

Libraries: biblioteca onde esta sendo criado o componente, neste exemplo, símbolo. 
Objects: selecione o objeto que se deseja inserir ao símbolo com um duplo clique, neste caso, 
ORIGIN. 
 

 
Figura 47: Janela Pick Symbols. 
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14. Selecione ORIGIN no seletor de objetos e posicione-o no símbolo, veja o exemplo da figura 48. 

 
 
 
 
 
 

 
 

 
Figura 48: Inserindo a origem em um dos pinos. 

 
15. Para salvá-lo como símbolo na biblioteca. Selecione o símbolo, clique sobre ele com o botão 

direito. Escolha a opção Make Symbol. Isto abrirá a janela Make Symbol, conforme figura 49. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 49: Janela Make Symbol. 
 
16. Escolha a biblioteca na qual será armazenado o símbolo, digite o nome do mesmo. 
 
17. Clique em OK para finalizar as configurações de criação de símbolos. 

 
No campo Type, selecione o tipo Graphic para indicar quais os elementos será 
somente símbolo. Os demais serão utilizados para a criação de componentes. 

 

5.3.1 – Criação de Símbolos a partir de símbolos da biblioteca 
 
Para alterarmos algum símbolo já existente, utilizamos o seguinte procedimento: 
 

� Inserir o símbolo desejado.   
� Selecioná-lo e clicar no menu: Library > Decompose   . 

 
Agora o símbolo já não estará mais agrupado, possibilitando a edição de qualquer 
um de seus elementos. Feito isto, siga o procedimento padrão para criação de 
símbolos, e armazene-o na biblioteca. 
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5.4 – Criação de Componentes 

 
A criação de componentes segue o mesmo procedimento da criação de símbolos, 
com a adição de alguns passos. 
 
Procedimento para criação de componentes 
 
Primeiramente siga os procedimentos de 1 a 16 no capítulo 5.3, para criação de 
símbolos. Após posicionar a origem no componente, faltará configurar os pinos do 
componente, abaixo segue as instruções: 
 

1. Clique no ícone Selection Mode  .  Dê um duplo clique sobre qualquer um dos pinos do 
componente. 

 
2. Abrirá a janela Edit Pin, veja figura 48. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 48: Janela Edit Pin 

 

3. Configure o pino, informando o nome do pino e número do pino, em seguida clique em NEXT 
para edição dos demais pinos do componente, veja o exemplo da figura 49. 
 

 
 
 
 
 
 
 

Figura 49: Componente configurado. 
 

4. Selecione o conjunto. Clique com o botão direito sobre o mesmo e escolha a opção: Make 

device  . Abrirá a janela da figura 50. 
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Figura 50: Janela Make Device para criar um componente. 

 
 

5. Na janela Device Properties, configure as informações do dispositivo e clique em NEXT. 
 

� Device Name - Nome do componente 
 

� Reference Prefix – Letra que é referência do componente U para CI, C capacitor, R 
resistor, etc. 
 

� External Module – Arquivo contendo o circuito interno deste componente, caso o mesmo 
tenha. 

 
6. Abrirá a janela de configuração do packagings. Para adicionar o package, clique em ADD 

(Edit Footprint). Será apresentada a janela Package Device, como mostra a figura 51. 
 
 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 

Figura 51: Janela Packege Device para seleção e configuração do circuito interno do 
componente. 
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Na janela Package Device, figura 51, clicando em Add, acessa-se a janela da 
biblioteca do ARES, que é a biblioteca dos símbolos PCB. 
 
Neste caso, foi associado ao componente o package DIL14. Nesta janela configure as 
informações: 
 

o Número de gates: quantos símbolos são necessários para o componente. Se número 
gates for maior ou igual a 2, o Power localizado em Type deverá estar selecionado em 
Common. 

 
o Associam-se os pinos de alimentação comuns e os outros pinos conforme a 

exigência. Perceba que ao atribuir um pino ao encapsulamento, este torna-se branco. 
 

o Todos os pinos deverão estar preenchidos para o footprint, caso contrário utilize o 
campo NC pin para indicar quais os números não serão conectados (separados por 
vírgula). Clique em Assing Package(s), para continuar. 

 
7. Veja na página o footprint do componente em seguida clique em NEXT. 

 
8. Em Component Properties & Definitions, selecione as propriedades do componente 

clicando sobre o botão New, veja figura 52. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 52: Janela Make Device para definição de propriedades. 
 

9. Informe as propriedades do componente em Property definition. Clique em Next. 
 
10. Na janela Device Data Sheet & Held Fill, figura 53, configure as informações: 

� Datasheet file name: (nome do arquivo ou do datasheet) 
� Download server: (servidor)   
� Download PATH: (endereço do site onde encontra-se o arquivo). 
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Figura 53: Janela Make Device para definição do Device Data Sheet & Help File. 

 
11. Clique em NEXT. 

 
12. Em Indexing and Library Selection, figura 54,configure a categoria, subcategoria, fabricante 

e em caso necessário, adicione as descrições do componente em Device description. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 54: Janela Make Device. 
 
13. Clique em OK para finalizar as configurações do dispositivo. 
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5.5 – Esquemáticos Multi Sheet 

 
Antes de tudo é necessário conhecer o conceito de Sheet, para trabalharmos com 
esquemáticos do tipo Multi-Sheet. 
 

� Sheet – É uma instância do ISIS onde inserido os componentes. As sheets 
podem ser classificadas como: Parent Sheet ou Root Sheet, Sub Sheet ou 
Child Sheet. Há uma hierarquia entre as Sheet, no topo desta hierarquia 
tem-se o Parent Sheet e no nível abaixo as Sub Sheets. 

 
O comando Inter-Sheet terminal é utilizado para gerar um esquemático multisheet. 
Para fazê-lo clique sobre o ícone .  
 
 
 
 
 

 

Figura 55: Ícone Inter-Sheet Terminal para seleção dos pinos. 

 
 
Escolha o tipo de pino que será utilizado, neste caso, para conexão entre folhas, 
são os pinos INPUT e OUTPUT, veja figura 55. 
 
 
Como exemplo para demonstrar esta função, será inserido um componente AND_2, 
um pino Power e um gerador de clock com 3Hz na área de edição conforme a figura 
56. 
 
 
 
 
 
 
 

Figura 56: Componente exemplo, porta lógica AND. 
 

 
Selecionar o comando Inter-Sheet Terminal, escolher o pino OUTPUT e conectá-lo 
na saída da porta AND. Com o comando Edit Component, dê um duplo clique 
sobre o pino de Output e defina um nome para mesmo, por exemplo, SIGNAL_AND. 
 
Feito isto, deve-se criar agora uma nova sheet com auxílio do comando New Sheet 

. Inseri-se nesta nova Sheet, um pino de entrada INPUT e edita-se o seu nome 
para SIGNAL_AND, insere-se um led e o pino de terra, conforme a figura 56. 
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Inicie a simulação  para fazer testes de conexão entre as folhas, o que fará com que 
o LED pisque. 
 
Obs.: O mais importante em um esquemático Multi-sheet é o nome dos pinos de 

entrada e saídas das folhas sejam iguais, pois a ISIS associa os circuitos 
através dos nomes dos pinos. 

 
 

5.6 – Subcircuitos 

 
Subcircuitos são componentes criados com pinos de entrada e saída, estão 
linkados a um circuito em outra folha. Os pinos de entrada e saída do componente 
devem ser os mesmos, do circuito representado. 
Antes de criar um subcircuito, acesse um exemplo disponibilizado trata-se do 
arquivo 741.DSN localizado na pasta de instalação:  
 
C:\...\Labcenter   Electronics\Proteus   7   Professional\SAMPLES\Graph   Based Simulation. 
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Ao abrir este exemplo, verifica-se um circuito com o amplificador operacional LM741, 
como mostra figura 57. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 57: Circuito com o amplificador operacional LM741. 
 
 

Ao clicar com o botão direito no amplificador operacional 741 e acessar a opção 
Goto Child Sheet , nele será observado o seu circuito primitivo conforme a figura 
58. 
 

 
 

Figura 58: Circuito primitivo do Amplificador Operacional LM741. 
 
 
Obs.:  Perceba que o amplificador operacional é um componente comum, porém em 

suas propriedades está habilitada a opção Attach Hierarchy Module, esta 
opção que permite utilizar a função Subcircuit em componentes do ISIS. 
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Utilize o comando Exit to parent sheet  para retornar à Parent ou Root Sheet.  
Agora será criado um novo arquivo, um subcircuit, utilizando o comando Sub-

Circuit .            
 
Perceba que no campo seletor de objetos são habilitadas algumas opções de Ports, 
para gerar subcircuito, veja figura 59. Crie o mesmo circuito exemplo do Multi-

sheets, conforme figura 60. 
 
 
 
 
 
 

Figura 59: Janela de Seletor de Objetos, opção Ports. 

 

 

 
 
 
 
 
 
 

Figura 60: Circuito exemplo com porta lógica AND. 
 
 

Gere o contorno do subcircuito, para fazê-lo é necessário selecionar as ports INPUT 
e OUTPUT e clique exatamente sobre a borda do subcircuito, criando as entradas e 
saídas conforme a figura 61. 
 
 
 
 
 
 
 
 
 

 
Figura 61: Criação de contorno do subcircuito gerando entradas e saídas. 

 
 
 
 
 
  

OBS:  Não esqueça de que cada entrada e saída deverá ter um nome, uma vez que 
o ISIS a associa com conexões entre as folhas através dos nomes lógicos. 
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Após isto, faça as conexões do gerador de Clock (3Hz),  do  Power,  do  Led  e  do 
GND, conforme a figura 62. 
 
 
 
 
 
 
 
 
 
 

Figura 62: Configuração do circuito subcircuito. 
 
 
 
Agora inicie a simulação, clicando no botão Run Simulation   
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6. RELATÓRIOS E VERIFICAÇÃO DE ERROS 
 

6.1 – Electrical Rule Check 

 
 
O Electrical Rule Check, é uma ferramenta do ISIS para verificação de erros, que, 
basicamente, informa dois tipos de erros: 
 

� Pontos desconectados (undriven) ; 
� Pinos sobrecarregados, drenando uma corrente maior do que especificado no componente. 

 
 
Utilize o arquivo Timer Mode.DSN, figura 63, que está localizado na pasta de 
instalação. 
C:\...\Labcenter Electronics\Proteus 7 Professional\SAMPLES\Interactive Simulation/Counter 
Timer 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 63: Circuito aberto pelo arquivo Timer Mode.DSN. 
 
 
Acessando o menu: Tools > Electrical Rule Check... ou clicando no ícone  será 
executado o Electrical Rule Check, como apresenta a figura 64.  Neste 
procedimento, automaticamente é gerado o Netlist e verificado os pontos de conexão 
do circuito, e em seguida, gerado o relatório. 
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Figura 64: Janela de execução do Electrical Rules Check. 
 
 
Neste arquivo são indicados dois erros de desconexão, sendo o ponto CV no 
componente U1 e o ponto CLK no componente Counter. 
 
Não é possível alterar qualquer opção do Electrical Rule Check, porém salvar o 
relatório em formato texto ou enviá-lo diretamente para o clipboard. 
 

6.2 – Bill of Material 

 
O ISIS permite gerar a lista de material do projeto em quatro formatos HTML, 
ASCII, Compact CSV e Full CSV. 
Acesse o menu: Tools > Bill of Material >...format Output  ou clique no ícone . 
 
Após abrí-lo, crie a lista de material, abrirá a janela representada pela figura 65. 
Neste exemplo, tem-se uma lista no formato HTML, que é o padrão do ISIS. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figura 65: Janela Bill of Material no formato HTML. 
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As lista podem ser geradas nos formatos informados anteriormente, para gerá-las 
acesse o menu: Tools> Bill of Materials. 
Os dados listados neste tipo de relatório são definidos no menu: System > BOM 
Scripts, onde é possível alterar e definir o tipo de dados que serão listados na lista 
de material. 

6.3 – Netlist 

 
O último processo será executado no ISIS é a geração do Netlist, para criação do 
layout. O Netlist é uma linguagem utilizada para descrever as conexões de um 
circuito, onde o software que desenhará o layout interpretará esta lista criando a 
conexão elétrica entres os componentes, obedecendo as pinagens descritas no 
netlist e, conseqüentemente, no esquemático. 
No ISIS é possível gerar Netlist em diversos formatos, que poderão ser importados 
para diversos softwares de layout do mercado. 
 
O menu: Tools > Net List Compiler..., permite escolher o formato no qual será 
gerado o Netlist. Isto abrirá a janela Netlist Compiler, como mostra a figura 66. 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Figura 66: Janela Netlist Compiler. 
 
 
Clique em OK pa ra  gera r  o Netlist e da mesma forma que os outros relatórios, 
salva-lo somente como arquivo texto. 
 
A fim de facilitar o trabalho e ter uma integração (interface de layout do Proteus), 
pode-se exportar diretamente o Netlist para o ARES, para isto, utilize o comando 
Generate Netlist and Switch to ARES, que pode ser acionado pelo ícone  ,ou 
pelo menu: Tools > Netlist to ARES. Com o arquivo CPU.DSN podemos realizar 
esta operação, porém antes de executa-la, é necessário apagar ou mover o arquivo 
CPU.LYT, localizado na pasta de instalação do Proteus, na rota: 
C:\...\Labcenter Electronics\Proteus 7 Professional\SAMPLES\Schematic & PCB Layout 
 
Este procedimento é necessário para que o comando não abra o arquivo já existente, 
onde layout foi criado. 
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7. ARES 7 PROFESSIONAL 
 
 
O ARES (Advanced Routing and Editing Software) é uma interface do Proteus para 
criação de layout de PCB sem esquemático. 
 
Antes de prosseguir com a criação do layout, do netlist exportado diretamente para o 
ARES, é preciso conhecer a interface de ferramentas e seus conceitos básicos. 
 
 
7.1 – Ambiente Gráfico do ARES 
 
Como foi dito anteriormente, o PROTEUS possui uma interface gráfica específica , 
com o mostra a figura 67, para o desenvolvimento de layout's, que segue o mesmo 
padrão da interface gráfica do ISIS. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 
Figura 67: Ambiente de Interface gráfica ARES. 
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7.2 – Barras de Ferramentas 

 
As barras de ferramentas do ARES estão distribuídas ao longo do topo e lateral 
esquerda da janela, estas são as posições padrões, mas também é possível alocar 
as barras de ferramentas nas bordas da janela, basta clicar e arrastar a barra para a 
posição desejada. 
 
A visualização das barras de ferramentas pode ser habilitar ou desabilitar, utilizando o 
mesmo procedimento do ISIS, acesse o menu: View > Toolbars... onde aparecerá a 
janela Show/Hide Toolbars. Segue abaixo as barras de ferramentas disponíveis no 
ISIS: 
 
 
.File / Print  
 
 
.Display Commands  
 
 
Editing  Command  
 
 
.Layout Tools  
 
 
.Placing & Routing  
 
 
.Pad Placement  
 
 
.2D Graphics 
 
 
Orientation Toolbar 
 
 
Selection Filter 
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7.3 – Opções e facilidades do ARES 

 
Como o ARES segue o mesmo conceito do ISIS, algumas opções tornam-se 
intuitivas, facilitando o uso desta ferramenta, o que permite focar nossa atenção nas 
particularidades desta interface. 
 
Unidade de Trabalho e Grid 
 
Pode-se trabalhar em milímetros ou polegadas, para configurar acesse o menu: View 
> Metric ou o ícone  , o Grid, pode ser alterado no menu: View > Snap..., onde 
temos até uma precisão de 1 mil (th) ou 100um. 
 
Layers 
 
O ARES trabalha com diversos layers ou camadas, cada layers recebe, quando 
necessário, um tipo de desenho, por exemplo, o layer Board Edge deverá conter 
somente o contorno da placa de circuito impresso.  
 
Uma função interessante é que o ARES seleciona somente os objetos que estiverem 
desenhados no layer ativo (layer selecionado no seletor de layer), o que possibilita 
maior segurança, pois, evitará editar, mover e efetuar outras operações com outros 
elementos. 
 
Um grupo de layers está disponível no seletor de layers, por exemplo, quando o 
comando component placement and editing  estiver ativo, somente os layers 
component side e solder side, estarão disponíveis, veja figura 68.  Para inserir uma 
trilha utilizando o comando track placement and editing  será disponibilizado o 
layers Bottom Cooper, Top Cooper e mais 14 layers Inner1 ao Inner14. 
 
 
 
 
 
 
 
 
 
 

 
Figura 68: Layers ativos com o comando Component Placement and Editing. 
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Figura 69: Layers ativos com o comando Track Placement and Editing. 

 
 
Segue abaixo três menus diferentes para configurarmos as opções dos layers, cada um 
com uma função específica: 
 

� View > Layers...  - Permite alterarmos as cores e visualização dos layers utilizados na 
placa. 
 

� System > Set Layer Usage... - Podemos definir se os layers especificados na janela Set 
Layer Usage, será habilitado no Track mode (desenho das trilhas) ou no Graphic mode. 
 

� System > Set Layer Pair... - Permite configurar os pares de layers que serão utilizados, 
quando inserimos uma via, por exemplo, uma via indo do Top até Bottom ou do layer Inner1 
até Inner2, etc. Esta função ficará mais clara quando utilizarmos a ferramenta track 

placement and Editing 
 
 
Extensões de Arquivos 
 
 
O ARES trabalha com as seguintes extensões de arquivos: 
 

.LYT – Arquivo de Layout. 
 
.LBK – Arquivo de Backup do Layout. 
 
.RGN – Arquivo Region contendo Layouts exportados. 
 
.LIB – Arquivo de Bibliotecas. 
 
.SDF – Arquivo contendo os Netlists. 
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Import e Export 
 
 
Os arquivos com extensões: DXF, Region (RGN) e imagens Bitmap, através do 
menu: File > Import... podem ser importados. Já o processo export se encontra no 
menu: Output > Export... e oferece uma variedade maior de arquivos onde podemos 
exportar os arquivos de layout para os formatos DXF, Region (.RGN), Bitmap 
(.BMP), Metafile (.EMF), EPS, Vector (.HGL) e Overlay (.BMP). Além destes 
formatos, é disponível exportar o layout em formato Gerber, acessando o mesmo 
menu. 
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8. CRIANDO LAYOUT'S 
 

O processo de criação de layout’s pode ser realizado por procedimentos diferentes, 
o mais importante é adequar as facilidades do processo de criação de layout’s a sua 
necessidade ou facilidade de utilização das ferramentas do ARES. 
 
 
8.1 – Importando o Netlist e Inserindo Componentes no Layout 
 
 
Existem dois procedimentos para importar um arquivo netlist, o primeiro basta acessar 
o menu: File > Load Netlist, ou diretamente através do ISIS, após o esquemático 
finalizado acessar o menu: Tools > Netlist to ARES  ou pelo ícone. 
Apesar destes procedimentos serem distintos, para o ARES ao fim do processo de 
importação, o resultado é idêntico. Prosseguindo com o arquivo exemplo: CPU. DSN 
que este localizado na pasta de instalação do PROTEUS, na rota: 
C:\...\Labcenter Electronics\Proteus 7 Professional\SAMPLES\Schematic & PCB Layout  
 
 
Lembrando:  O arquivo .DSN deve ser aberto no ISIS, após isto, geraremos o netlist e carregá-lo 

diretamente no ARES, utilizando o comando Tools > Net List to ARES. Após carregá-
lo, obtem-se no seletor de objetos, todos os componentes que compõem o circuito, 
conforme a figura 70, e para inserí-los  na  área de edição basta selecioná-los, e 
clicar sobre o local que deseja-se inseri-lo. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Figura 70: Janela de seletor de objetos com todos os componentes que compõem o circuito. 
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Observe que ao inserir os componentes na local desejado, estes sairão da lista do 
seletor de objetos, o que serve como parâmetro para certificar-se de que todos 
os componentes foram inseridos no layout. Se um dos componentes for deletado da 
janela de edição, o mesmo retornará a lista do seletor de objetos. 
 
Quando os componentes são inseridos, aparecerão linhas verdes (ratsnest) e setas 
amarelas (vectors) esta visualização pode ser desabilitada, pela janela Display 
Layers.  Esta simbologia informa de que pino a que pino deve ser desenhada uma 
trilha (ratsnest) e em que direção o componente pode ser colocado, para diminuir a 
distância entre as conexões (vectors), veja ilustração da figura 71. 
 
O procedimento para manipulação dos componentes inseridos, mover, deletar, 
copiar, é o mesmo utilizado no ISIS. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Figura 71: Janela Display Layers. 
 
 

8.2 – Criando o Board Edge 

 
Antes de inserir os componentes, é preciso criar o Board Edge ou borda da placa 
na área de edição, ou importarmos esta informação de um arquivo DXF.  A borda 
deve ser desenhada no layer Board Edge e eventuais rasgos ou aberturas para 
encaixe mecânico, que sejam necessários, devem ser desenhados no layer mech1, 
mech2, etc, que são específicos para este fim. 
 
Selecionando primeiro o layer, que os elementos ficaram e utilizando as ferramentas 
de desenho da barra 2D Graphics, pode-se desenhar a borda e eventuais rasgos. 
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8.3 – Roteamento Manual 

 
O comando track placement and edit  serve para fazer o roteamento manual, 
onde será criada a trilha clicando sobre  qualquer pino, veja figura 72. Este 
comando também é utilizado para edição de uma trilha que já foi inserida no layout.  
 
Ao iniciar o processo de roteamento percebe-se que o pino, onde a trilha deve ser 
finalizada, é selecionado e a direção é indicada por uma seta, como mostra a figura 
72.  Caso a trilha seja conectada a outro pino, por engano, esta trilha ficará 
“piscando” na cor amarela. 
 
 
 
 
 
 
 
 

Figura 72: Processo de roteamento dos pinos. 
 
Durante o processo de inserção das trilhas manualmente, pode haver a 
necessidade de um outro layer, por exemplo, o Bottom layer, temos que passar 
uma via, continuar no Top Layer e retornar ao Bottom layer. 
 
O processo pode ser realizado com um duplo clique sobre o ponto onde deseja-se 
inserir a via e, automaticamente, continuaremos o roteamento no Top Layer.  A 
configuração dos pares de layers que são utilizados nesta facilidade, é realizada no 
menu: System  >  Set  Layer pairs ... A figura 73 ilustra a configuração dos layers.  

 

 

 

 

 

 

 

Figura 73: Configuração dos layers. 

 

O comando da barra de ferramentas, placement and editing  permite inserir vias fora 
do processo, ou mesmo vias já roteadas.   

 

O ARES possui uma ferramenta de verificação de erros, que pode estar habilitada 
automaticamente, para verificar e indicar erros ou ser habilitada manualmente para 
verificação posterior dos erros. 
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No menu: Tools > Design Ruler Checker é possível alterar o status desta 
ferramenta, que utiliza os valores de tolerância configurados no menu: System > Set 
Default Rules ... 
 
Na janela Default Design Rules, pode-se configurar os valores mínimos das 
distâncias entres pad-pad; pad- trilha; trilha-trilha; Graphic-Net e Edge-Net.  
Sendo as duas últimas, as menores distâncias entre os desenhos silk-screen e 
qualquer outro elemento, e a menor distância entre a borda da placa e qualquer 
outro elemento, respectivamente.   Além destas opções é possível configurar a 
tolerância para curvas e estreitamentos de trilhas (neck style). 
 

8.4 – Auto Placer 

 
A função Auto Placer permite inserir todos os componentes de forma automática 
dentro de uma área específica que é definida pela borda da placa, pois sem esta, o 
comando não executaria a operação. Acione o comando no menu: Tools > Auto 
Placer... ou pelo ícone  , a janela, como mostra a figura 74, Auto Placer se abrirá. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figura 74: Janela de configuração Auto Placer. 

 
 
Nesta janela Auto Placer tem-se o campo do lado esquerdo com os componentes 
que podem ser selecionados para inserção e do lado direito, os campos que definem 
o método que será utilizado para inserir os componentes.   
 
Caso alguns componentes que já tenham sido inseridos e não apareceram na lista e 
seu posicionamento relativo aos componentes não mudará, porém se a opção: Push 
& Shove, não for desabilitada seu posicionamento em relação à placa será alterado. 
 
Dependendo da complexidade do circuito é recomendado que os componentes 
sejam inseridos manualmente. 
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Exemplo Auto Placement 
 
No exemplo CPU.LYT, após retirar todos os componentes inseriremos somente os 
conectores J1, J2, J3, J4 e J5, em seguida, utilizar o auto placer diversas vezes, 
alterando-se as opções Push & Shove habilitada e desabilitada e alterar os valores 
dos campos Design Rule, Prefered DIL Rotation, Options e Trial Placement Cost 
Weightings. 
8.5 – Auto Router 
 
 
É uma função que realiza todo o processo de roteamento automático, facilitando o 
trabalho do projetista, principalmente, em circuitos com muitos componentes, 
conforme o posicionamento dos mesmos de as configurações das estratégias de 
roteamento.  
 
Através do menu: Tools  >  Auto  Router... pode-se acessar  a  janela auto router, 
figura 75, onde podemos configurar o grid como roteador  (quanto menor mais 
demorado o processo e mais preciso), proteção às trilhas já roteadas (protect 
manual tracks) e outras   opções   para   o   roteamento.   Clicando no botão Edit 
Strategies, acessa-se as estratégias que serão utilizadas no roteamento, que podem 
ser configuradas na janela Edit Strategies., figura 76, para o roteamento, que será 
realizado. 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 75: Janela de configuração do Auto Router. 
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Figura 76: Janela Edit Strategies para realização do roteamento. 

 
A opção Strategy define como será roteado o sinal lógico (SIGNAL), o sinal de 
alimentação (POWER) e os barramentos (BUS), de forma independente entre eles. 
As opções são habilitadas de acordo com o projeto, por exemplo, caso um projeto 
não tenha barramento a opção BUS, não aparecerá na lista. No campo Priority 
selecionar a prioridade para roteamento, quanto menor o número maior a prioridade 
e, consequentemente, o roteamento será realizado primeiro. Também pode-se 
selecionar se será utilizado somente uma layer ou pares de layers, nos campos 
Pair. 
 
No campo Corners, selecione como os cantos das trilhas serão desenhados não 
podendo escolher um ângulo de inclinação para os cantos. Para os cantos “fora do 
padrão” podemos alterá-los depois de realizado o roteamento acessando o menu:  
Edit > Mitre... onde é possível definir a mínima e máxima distância conforme a figura 
77. 
 
 
 
 
 
 
 
 

Figura 77: Alteração das distâncias mínimas e máximas dos cantos. 
 
 
 
 
 
 
Utilizando o exemplo CPU.LYT disponibilizado na pasta de instalação do PROTEUS, 
conforme o caminho: 
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C:\...\Labcenter  Electronics\Proteus  7  Professional\SAMPLES\Schematic  &  PCB  
Layout 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 78: Disposição dos componentes na placa. 

 

Utilizaremos este arquivo para realizar o Auto Router.  A disposição dos 
componentes na placa é sugerida conforme o exemplo da figura 78. 
 
Vamos configurar as prioridades de roteamento para 1- POWER, 2-BUS e 3-SIGNAL 
e, respectivamente, utilizar no Trace Style T30, T20 e T15. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 79: Disposição dos componentes na placa após configuração 
 da propriedades de roteamento. 

 
Após configuradas estas opções executando o auto router, tem-se como resultado 
conforme a figura 79. Como exercício alterar as outras opções das estratégias e 
avaliar o resultado. 
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8.6 – Criando Planos de Terra ou Vcc. 
 

A barra de ferramentas Zone placement and Editing , permite criar planos. Ao 
clicarmos no comando, podemos definir a área em que será criado o plano, em 
seguida abr i rá  a janela, como mostra a figura 80.   
 
Depois de criado o plano, este estará no layout e caso seja necessário editar alguma 
trilha, automaticamente o plano se adequará a nova situação, porém alguns em 
casos pode ser necessário recriar o plano. 
 
 
 
 
 
 
 
 
 
 
 

Figura 80: Janela Edit Zone. 
 

 
Na janela Edit Zone, figura 80, pode-se configurar as seguintes opções: 
 
 
� Net - Define o net que estará conectado ao plano, geralmente VCC ou GND. 
 
� Layer - Define o Layer que o plano fará parte, com a possibilidade de alterarmos a cor do plano, 

selecionando a opção custom. 
 
� Boundary – Define o o estilo de trilha e a menor secção que o plano se conectará, quanto 

maior o valor os espaçamentos, por exemplo entre os pads, não terão cobre. 
 
� Relief – Especifica o estilo de trilha que o thermal Relief se conectará aos pinos dos 

componentes. 
 
� Type – Tipo de Preenchimento que o plano utilizará. 
 
� Clearance – Define a menor distância entre o plano de cobre e qualquer elemento do layout. 
 
� Relief Pins – Define a conexão de thermal relief, conforme especificado no item relief. 
 
� Exclude Tracking – Apaga as trilhas que estão conectadas ao plano. 
 
� Suppres Island – Permite que o Auto router, utilize o processo auto via, para pads SMD. 
 
� Route to this Zone – Utilizando o Auto Router, rotea para o plano qualquer trilha que esteja 

conectada a ele. 
 
 



 

 66

 PROTEUS 

ANACOM ELETRÔNICA LTDA 
Fone/Fax: (11) 3422-4200 

 www.anacom.com.br 
 

 
Trabalhando ainda com o exemplo CPU.LYT, será criado um plano utilizando o 
Layer Top Cooper e o Net VCC como é apresentado na figura 81. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 81: Plano criado a partir do Layer Top Cooper e o Net VCC. 
 
 
Obs: Observe que neste exemplo existem áreas, onde não há cobre, isto ocorre, 
pois elas estão isoladas e não tem conexão com o restante do plano, é uma 
característica do ARES para calcular o plano desta maneira. 
 
Este detalhe pode ser minimizado se as distâncias forem reduzidas, entre os pads e 
thermal relief, clearance do plano e algumas regras do projeto, porém este 
procedimento não é recomendado. 
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8.7 Criando Packages 

 
O ARES possui várias bibliotecas de símbolos e encapsulamentos (Packages), 
organizadas da mesma forma que o ISIS, sendo que 2 bibliotecas de símbolos 
compartilhada com o ISIS e 6 bibliotecas de packages, que podem ser acessadas 
pelo menu:  Library > Pick Package/ Symbol ou pelo ícone .  
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figura 82: Janela do Pick Package para acesso a biblioteca de símbolos. 

 
 
Abrirá a janela apresentada na figura 82, perceba que ela segue o mesmo padrão do 
ISIS. 
 
O PROTEUS possui em sua pasta de instalação um guia em PDF, o arquivo 
Library.pdf, que contém as informações sobre todas as bibliotecas e seus desenhos. 
É possível acessá-los no diretório: 
C:\...\Labcenter Electronics\Proteus 7 Professional\LIBRARY 
Em alguns casos, é necessário criar novas representações de encapsulamento, para 
isso, utilizamos, basicamente, duas barras de ferramentas, figura 83, a 2D Graphics 
e Pad Placement. 
 
 
 
 
 

Figura 83: Barras de ferramentas 2D Graphics e Pad Placement. 
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Procedimento para criação de componentes no ARES 
 

1. Acesse o menu: View > Metric, para configurar a padrão de medida que pode 
ser em polegadas ou milímetros. 
 

2. Ainda no menu View, defina o tamanho adequado para visualização da janela 
de edição, selecionando um dos parâmetro disponíveis conforme figura 84.  

 
 
 
 
 
 

 
 

Figura 84: Parâmetros de visualização da janela de Edição do ARES. 
 
 

3. Clique sobre o ícone Dimension Mode  para dimensionamento da borda do 
componente conforme figura 85. 

 
4. Selecione o ícone 2D Graphics Box Mode  para desenhar a borda do 

componente de acordo com o dimensionamento definido anteriormente, figura 
85. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figura 85: Dimensionamento e desenho da borda do componente. 

 

5. Escolha o pad ideal para o componente, para o exemplo, selecione o ícone 
Round Through-hole Pad Mode   e posicione-os como na figura 86. 
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6. Faça o esboço interno utilizando o 2D Graphic Line Mode e para fazer o 
desenho da meia volta, selecione o ícone 2D Graphic Arc Mode , veja figura 
86. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

Figura 86: Desenvolvimento do componente. 

 
7. Remova a borda de externa bem como os dimensionamentos. 

 
8. Configure, nomeie os pads dos componentes, para isto, dê um duplo clique 

sobre qualquer um deles, abrirá a janela Edit Single Pin, apresentada pela 
figura 87 e a ilustração dos pads configurados na figura 88. 
 
 

 
 
 
 
 
 
 
 
 

Figura 87: Janela Edit Single Pin. 
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Figura 88: Pads do componente configurados. 

 
9. Posicione a origem do componente, para fazê-lo, clique sobre o ícone 2D 

Graphics Markers Mode e selecione a opção ORIGIN no seletor de objetos. 
 

10.  Selecione o conjunto e clique com o botão direito sobre o mesmo, abrirá um 
menu, figura 89. Escolha a opção Make Package a fim de configurar o 
encapsulamento.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figura 89: Menu Make Package para configuração do encapsulamento. 
 

11.  Abrirá a janela Make Package, representada pela figura 90, na qual faremos a 
configuração de biblioteca: nome, categoria, tipo, referente ao package em 
questão. Na aba 3D Visualization é possível visualizar o encapsulamento em 
3D, conforme figura 91. 
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Figura 90: Janela Make Package para configuração da biblioteca. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Figura 91: Janela Make Package para visualização em 3D do package. 
 
 
Para alterar as configurações de visualização em 3D: 
 
Corpo Tipo Estruturado (default) 
Os padrões de propriedades para configurar o layer do tipo estruturado, seguem 
abaixo: 
 
 
COLOUR  R, G, B valores para a cor do corpo do componente. 
MINHEIGHT  Especifica a altura inferior do corpo sobre a placa. 
MAXHEIGHT  Especifica a altura superior do corpo sobre a placa. 
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X Especifica a distância da origem do corpo a origem da placa no eixo X. 
Y Especifica a distância da origem do corpo a origem da placa no eixo Y. 
ANGLE O ANGLE especifica as informações relativa ao ângulo, por exemplo, 

ANGLE=45; 
 
Corpo Tipo CuboID  
 
Os detalhes seguintes possibilitam as configurações das propriedades do corpo do 
tipo cubo: 
 
TYPE  Selecione o tipo de corpo: CUBOID (neste caso). 
COLOUR R, G, B valores para a cor do corpo. 
MINHEIGHT Especifica a altura inferior do corpo com relação à placa. 
MAXHEIGHT Especifica a altura superior do corpo com relação à placa. 
X  Especifica a distância da origem do corpo a origem do gráfico da placa, no eixo X. 
Y  Especifica a distância da origem do corpo a origem do gráfico da placa, no eixo Y. 
SX  Especifica o tamanho da largura do cubo. 
SY  Especifica o tamanho do comprimento do cubo.  
ANGLE O ANGLE especifica as informações relativa ao ângulo, por exemplo, ANGLE=45; 
 
 
Segue um exemplo de um corpo configurado como CUBOID: 
 
TYPE=CUBOID 
MINHEIGHT=1mm 
MAXHEIGHT=5mm 
COLOUR=(20,20,20) 
X=6.5mm 
Y=1mm 
SX=20mm 
SY=5mm 
 
Corpo do Tipo AXIALCYLIDER  
 
Os detalhes seguintes possibilitam as configurações das propriedades do corpo do 
tipo axial-cylinder: 
 
TYPE Selecione o tipo do corpo, neste caso, AXIALCYLINDER. 
COLOUR R, G, B valor da cor do corpo. 
MAXHEIGHT Especificar a altura superior do corpo com relação à placa. 
X Especifica a distância da origem do corpo do gráfico da placa, no eixo X. 
Y Especifica a distância da origem do corpo do gráfico da placa, no eixo Y. 
LENGTH Selecione o comprimento do cilindro. 
ANGLE O ANGLE especifica as informações relativa ao ângulo, por exemplo, ANGLE=45; 
RADIUS  Controla o raio do cilindro sobre o cylinders axis. 
BAND  Selecione a posição e a cor a banda de resistência. 
 
As propriedades do raio são dadas da seguinte forma:  
 
RADIUS=P1,P2,P3,P4 
 
Onde: 
 
P1 Controla o raio vertical do cilindro. 
P2 Controla raio horizontal do cilindro. 
P3 Controla a profundidade do raio no cilindro central. 
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P4 Controla a profundidade do raio ao longo da linha central do cilindro. 
As propriedades de faixa são dadas da seguinte forma: 
 
BANDx=P1,P2,(r,g,b) 
 
 
Onde x pode ser um número de 1 a 9 e: 
  
P1 O ponto de partida da faixa ao longo da linha central do cilindro; 
P2 O ponto final da faixa ao longo da linha central do cilindro; 
RGB O valor da cor da faixa. Se omitida, a cor default será calculada do campo de valor dos 

componentes, permitindo o código de cores automático dos resistores etc. 
 
 
TYPE=AXIALCYLINDER 
MAXHEIGHT=2 
LENGTH=0.2in 
RADIUS=0.027in,0.027in,0.2mm,0.2mm 
X=0.2in 
Y=0.0in 
COLOUR=(128,64,64) 
BAND1=20,25 
BAND2=30,35 
BAND3=40,45 
BAND4=50,55 
BAND5=80,85 
 
 
Tipos de pino  
 
Há sete tipos de pinos disponíveis para uso: 
  
NONE               STRAIGHT       BENTWIRE             SMTZ 
SMTJ   SMTB    CUBOID 
 
 
Estes defaults tendem a trabalhar bem, porém quando for necessário pode-se atribuir um pino 
específico datilografá-lo, isto é, PINTYPE=xxxxxx. As propriedades adicionais que podem ser 
aplicadas aos pinos são:  
 
PINCOLOUR R, G, B valor da cor do corpo. 
PINMAX Indica a extensão mais elevada do pino da superfície da placa e é usada por todos 

os tipos do pino.  
PINMIN Indica a extensão mais baixa da superfície da placa. 
PINDIAMETER Para os pinos STRAIGHT e BENTWIRE, este controle do diâmetro dos pinos. Para 

o pino SMTB ele controla o diâmetro do hemisfério. 
PINLENGTH Para os pinos SMTJ e SMTZ controla comprimento da base do pino. 
PINTHICKNESS  Para os pinos SMTJ e SMTZ isto controla a espessura do pino. 
PINWIDTH Para os pinos SMTJ e SMTZ isto controla a largura do pino. 
PINMOVE Este comando move os pinos para mais próximo ou mais longe do limite do corpo 

do componente pela quantidade de faixa especificada. 
 
 

OBS:  Estas e outras informações estão mais bem detalhadas no menu: Help > Help Index, 
onde abrirá a janela Ares Help. 
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12. Clique em OK para confirmar suas configurações. 
13. Observe que o nome do Package aparecerá no seletor de objetos. 
14. Verifique o componente na biblioteca do ISIS. Caso não tenha sido gerado 

componente na biblioteca, siga o procedimento a seguir para associá-lo ao 
componente novo na biblioteca ISIS: 

a. Abra o ambiente ISIS; 

b. Selecione um componente já existente na biblioteca do ISIS, que mais se aproxime do 

componente criado na biblioteca do Ares, como exemplo, será utilizado CONN-H10, figura 

92, por possuir 10 pinos. 

 

 

 

 

 

 

 

Figura 98: Componente CNN-H10 da biblioteca ISIS. 

 

c. Selecione-o, clique com o botão direito do mouse sobre o mesmo e escolha a opção 

Packaging Tool. 

d. Abrirá a janela Package Device, conforme figura 93. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 93: Janela Packaging Device. 
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e. Selecione, nesta janela, o botão Add e escreva o nome do componente (o mesmo criado 

na biblioteca Ares); 

f. No canto superior à esquerda ative o campo Default package. 

g. Selecione o botão Assingn Packages, isto abrirá a janela Select Package Device, figura 

VV, na qual deve-se selecionar a biblioteca; 

h. Salve o componente na biblioteca clicando sobre o botão Save Package(s). 

i. Na terceira janela ISIS Professional se é de interesse fazer o UPDATE do dispositivo. 

Clique em YES para confirmar. 

 

O componente agora está pronto para ser utilizado e configurar suas propriedades. 

8.8 – Gerando arquivos CAM (Gerber) 

 
 
Os arquivos gerber, podem ser criados acessando o menu: Output > CAD CAM 
output..., isto abrirá a janela CADCAM (Gerber and Excellon) Output, figura 68, onde 
é definido os layers que participaram do gerber e o formato do gerber RS274D 
(vetorial) ou RS274X(raster), onde recomenda-se sempre utilizar o formato RS274X. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Figura 68: Janela CADCAM (Gerber and Excellon) Output. 
 

Após exportar o projeto para o formato gerber, visualize o resultado acessando a 
ferramenta Gerber View, através do menu: Output > Gerber View..., onde também é 
observa-se os arquivos gerber gerados por outros softwares. 
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8.9 – Visualização em 3-D 

 
 
Uma inovação interessante nessa versão do Proteus é a visualização da placa e de 
seus componentes em 3D. Como exemplo, será utilizado o arquivo CPU.LYT, 
localizado no seguinte diretório: 
 
 
 
C:\...\Labcenter Electronics\Proteus 7 Professional/SAMPLES/Schematic & PCB Layout 
 
 
 
Primeiramente deve-se inserir os componentes e roteá-los, em seguida, acesse o 
menu: Output > 3D Visualization. A janela Cpu-3D Visualization, figura 69, abrirá. 
 

 
Figura 69: Imagem gerada em 3D para observação da placa e seus componentes. 
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O menu View possui praticamente, as mesmas opções presentes na barra inferior da 
visualização, que são: 
 
 

� Center at Cursor: Quando pressionada, transforma o cursor numa mira que ao receber o 
clique centraliza a visualização do circuito no ponto onde está. 

 
� Zoom In: Aumenta a aproximação 
 

� Zoom Out: Diminui a aproximação 

 

� Top View: Visualiza a placa por cima 

 

� Front View: Visualiza a placa pela frente 

 
� Left View: Visualiza a placa pela esquerda 
 

� Back View: Visualiza a placa por trás 

 

� Right View: Visualiza a placa pela direita 
 
 
Ainda temos as opções Regenerate, que faz a placa 3-D retornar ao estado original do 
layout e a função Auto- Spin que faz com que a mesma fique girando na tela. 
 
 
O menu Settings disponibiliza as seguintes funções: 
 

� Dimensions: Permite modificar a espessura da placa e das trilhas 
 
� Colours: Permite modificar a cor dos elementos da representação 3-D 

 
� Camera: Permite alterar o ângulo e a intensidade do brilho da “câmera". 
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9. - Passo a passo 
9.1 - Tutoriais 

 
 

9.1.1 - Configuração de Atalhos no Teclado 
 

 
O Proteus, seja no ambiente de trabalho Isis ou Ares, não obedece alguns comandos 
de teclado padrões do Windows ou outros softwares do mesmo segmento. Entretanto, 
ele oferece cada função para ser associada com a tecla que o usuário decida. 
 
Para isto, acesse a opção “Set Keyboard Mapping” através do caminho: 
 
 
“System” →→→→ “Set Keyboard Mapping...” 
 
 

 
Figura 70: Caminho de SET KEYBOARD MAPPING... 

 
Uma janela irá se abrir, oferecendo todos os comandos e os devidos caminhos para a 
definição do atalho de teclado. 
 
 
→ Primeiro, selecione o tipo de comando na lista de seleção (Command Groups): 
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Figura 71: Seleção do Grupo de Comando 

 
Aconselhamos que mude ao menos as opções: 
 
-Selection Mode (Mode selection Commands)     Hotkey: ESC 
-Rotate Clockwise (Orientation Bar Commands)    Hotkey: R 
-Block Copy (Application Miscellaneous Commands)   Hotkey: Ctrl+C 

 
Exemplo de alteração: 
 

→Selecionar o Grupo de comando: 
 

 
Figura 72: Seleção do Grupo 
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→→→→Selecionar o comando a ser alterado: 

 

 
Figura 73: Seleção do Comando 

 
 
 

→Após selecionar o comando, uma barra de inserção de texto será habilitada 
logo abaixo. Clique nesta barra em branco pressione a tecla que gostaria que fosse 
o atalho para este comando. Não é necessário digitar o nome da tecla. 
 
→Aparecendo o nome da tecla, é só clicar em Assign, para associar a tecla ao 
comando. 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figura 74: Associação de Tecla e comando. 

 

 

9.1.2 - Como posicionar uma falsa Origem 
 
Posicione o cursos do Mouse onde desejar que seja a nova origem. Oriente-se pela 
barra de status que exibira as cordenadas cartesianas em Mills. 
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Uma forma de melhorar a precisão do posicionamento, é alterando a largura do grid na 
aba “VIEW”, posicionando o cursor do mouse na coordenada (0,0) e deslocando 
através do uso das setas do teclado. 
 
Após concluir o posicionamento da nova origem, precione a tecla ‘O’. As coordenadas 
irão se alterar para (0,0), e sua cor se tornará lilás. Agora esta será sua origem. 
 
 
 
 
 

9.2 - Exercícios - Tutoriais 
 
Abaixo estão listados todos os exercícios do Treinamento presencial de Proteus. 
Os exercícios abaixo podem ser encontrados no seguinte endereço: 
 

http://goo.gl/6matv 
 
 

� Exercício 1 – Criação do Template 
 
Antes da criação do template, siga o seguinte caminho: 

 
Menu Template > Go To Máster Sheet 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Obs: Verifique se realmente você esta trabalhando no Master Sheet através da 
barra de status: 
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Para criação do Template utilizaremos o menu de edição de gráficos. 

 
Como: 
 

• 2D Graphics Line Mode 
 
• 2D Graphics Rectangle Mode 

 
• 2D Graphics Text Mode 

 
Lembrando-se de selecionar no “Seletor de Objeto”  a opção “Template” 
 

 
 
 
 
 
 
 
 
 

 
 
 
 

Lembrando que o comando “2D GRAPHICS TEXT MODE” pode ser usado para definir 
opções variáveis de  edição de propriedades de projeto. Como por exemplo, Titulo / 
Nome / N º de Pagina.. 

 
Em “String” podemos definir algumas informações como: 
@DTITLE :Titulo do Projeto 
@STITLE : Nome da Página 
@AUTHOR: Nome do Autor 
@PAGECOUNT: Nº de Pag. 
@PAGENUMBER: Nº da Pag. 
@CDATE: Data de Criação 
@MDATE: Data de Modificação 
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Primeiramente criaremos a nossa área de template,  
Utilize o “Rect Mode” 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Agora iremos definir onde irá conter todas as informações do nosso projeto.  
Utilize o “Line Mode” 

 
 

E finalizaremos com as edições de texto dentro do nosso template 
Utilize o “Text Mode” 

 

   
“Este Documento é Confidencia, de propriedade da “Empresa”. 
  Proibida sua Produção Total ou Parcial sem Previa Autorização 
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Após criar todos os campos, utilize nos campos em branco as devidas Funções para 
automatização das informações no template. 
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Funções: 
 
@DTITLE Título de Design de acordo com o menu Design > Edit design Properties 

@STITLE Título de Sheet de acordo com o menu Design > Edit sheet Properties 

@DOCNO Número de Design de acordo com o menu Design > Edit design Properties 

@REV Número da Revisão de acordo com o menu Design > Edit design Properties 

@AUTHOR Nome do Autor de acordo com o menu Design > Edit design Properties 

@CDATE Data de criação do desenho – Formato fixo e dado não alterável 

@MDATE Data de modificação do desenho – Formato fixo e não alterável 

@WL CDATE Data de criação do desenho de acordo com o padrão Windows, “long date format”. 

@WS MDATE Data de modificação do desenho de acordo com o padrão Windows, “short date format”. 

@CTIME Hora de criação do desenho de acordo com o padrão Windows, “time format”. 

@MTIME Hora de última modificação no desenho de acordo com o padrão Windows, “time format”.  

@PAGENUM Número corrente da página das folhas no projeto. 

@PAGECOUNT Número total de folhas do projeto. 

@PAGE Número da página na folha do projeto padrão – n da pág./n. total de folhas. 

@FILENAME Nome do arquivo .DSN 

@PATHNAME Nome do arquivo .DSN e todo caminho das pastas, onde se encontra o arquivo. 

 
Para definição das informações nos campos preenchidos, navegue até o caminho: 
 
 
“Design” →→→→ “Edit Design Properties...” & “Design” →→→→ “Edit Sheet Properties...” 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 75: Configurações do Projeto. 
 
Preenchendo estas informações, execute um “Zoom In” e um “zoom out” através do 
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scrol do mouse para dar um “Refresh” no sistema e atualizar as informações no layout. 
 
 
 
 

� Exercício 2 – Captura de Esquemático 
 
Criação do circuito RC e análise da curva característica do Capacitor. 
 
Para selecionarmos o componente devemos seguir o seguinte caminho para abrir a 
biblioteca de componentes. 
 
→→→→ Component Mode  →→→→ Pick from Library 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 76: Caminho da Biblíoteca. 
 
Na Biblioteca de componentes haverão as opções de filtro para seleção. Lembre-se de 
escolher um componente que possua um footprint já associado. 
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Figura 77: Biblíoteca e Footprint. 
A seleção é feita através de um duplo clique do mouse sobre o nome do componente 
que deseja utilizar. Este componente irá ser enviado para a lista de ‘devices’, no 
ambiente de trabalho: 
 
 
 
 
 
 
 
 
 

Figura 78: Componente. 
 
Neste Exemplo, analisaremos a curva característica de carga e descarga do capacitor 
C1, através de 2 métodos de análise. 
 
Elabore o circuito abaixo utilizando os seguintes componentes: 
 
-RES 
-BATTERY 
-CAPACITOR (ACTIVE) 
-SW-SPST 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 79: Esquematico – Curva característica do capacitor. 
 
A Ponta de prova R1 localizada no sistema se encontra na barra lateral esquerda.  
Existe também uma ponta de prova para corrente. 
 
Não é necessário abrir o circuito para utilização das pontas de prova, somente as 



 

  88

PROTEUS 

 

ANACOM ELETRÔNICA LTDA 
Fone/Fax: (11) 3422-4200 

 www.anacom.com.br 
 

conecte e durante a simulação o valor será exibido em tempo real. 
 
 
Análise Gráfica Estática 
 
O gráfico estático para análise do comportamento do capacitor em determinado 
período de tempo se encontra na opção “Graph Mode”. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 80: Seleção de Gráfico. 
 
Em graph mode, deverá ser especificado o tipo de gráfico, de acordo com o tipo de 
análise. 
A primeira opção, “Analogue”, se refere ao sinal da fonte, seja corrente ou tensão. 
 
Utilizando a ferramenta Analogue, dentro de Graph Mode, desenhe um quadrado no 
ambiente de trabalho. Note que após selecionar Analogue, o cursor do mouse se 
tornará um lápis verde. Isto significa que você já pode desenhar a região que o gráfico 
ocupará dentro do ambiente de trabalho. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 81: Gráfico sem informação. 
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O gráfico fica posicionado na área de trabalho, sem informação alguma. Para adicionar 
as informações ao gráfico, clique sobre ele com o botão direito do mouse, e selecione a 
opção “Add Trace”. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 82: Caminho para “Add Trace”. 
 
Após isto, a seguinte janela irá se abrir. 
Nesta janela, você deverá descrever quais sinais serão exibidos no gráfico, de acordo 
com as pontas de provas posicionadas anteriormente. 
 
Note que existem campos para inserção das pontas de prova. Entretanto, caso deseje 
plotar mais de uma informação de sinal no mesmo gráfico, este não é o caminho. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 83: Especificação de Informações do gráfico estático. 
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Note que, caso adicione em P1 a primeira ponta de prova, e em P2 a segunda, o 
campo “Expression” irá ficar da seguinte maneira: 
 
] 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 83: Exemplo de Erro ao adicionar pontas de prova. 
 
A expressão será uma soma, isto resultará em uma única linha de informação no 
gráfico, com a soma dos 2 sinais. Provavelmente este não é o efeito desejado. 
Para inserir 2 informações, primeiro adicione somente uma ponta de prova, aperte OK, 
acesse “add trace” novamente, adicione no campo P1 a segunda ponta de prova, e 
aperte OK. 
 
Repita este processo para a inserção de todas as pontas de prova que desejar plotar 
neste mesmo gráfico. 
 
Após inserir as pontas de prova, o gráfico terá o seguinte aspecto: 
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Figura 84: Gráfico com informações não processadas. 
 
Clique sobre o gráfico com o botão direito do mouse novamente, e clique em 
“Simulate”. A forma de onda será simulada de acordo com o estado do circuito. 
Caso a chave SW esteja aberta, o sinal ficará em zero. Desta forma, é possível 
analisar somente a curva de carga do capacitor. 
 
Após simular, o gráfico terá o seguinte aspecto: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 85: Gráfico com as informações já simuladas. 
 
OBS: 
O Gráfico acima esta correto, porém, haverão erros nos valores da simulação caso  
exista o TERRA. O elemento “Ground” no Proteus realiza a função de referência de 
cálculos ( “0” ) para os modelos SPICE e PSPICE envolvidos. Caso o sistema não 
possua referências, o calculo será feito somente com os valores indicados pela fonte e 
pontas de prova, interferindo assim na realidade da simulação. 
 
 
Curva de carga e descarga no modo estático: 
 
Como não é possível manipular o estado das chaves entre os instantes de simulação, 
iremos inserir uma fonte geradora de pulsos ao sistema. (A fonte geradora de pulsos se 
encontra em GENERATOR MODE  
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Figura 86:Gerador de Pulsos. 
Ajustando a fonte para trabalhar em uma freqüência de 0.25Hz e com valor Maximo de 
5v, clique sobre o gráfico e execute a função “Simulate Graph” novamente. 
 
Ele agora terá o seguinte aspecto: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Figura 87: Gráfico re-simulado. 
 
 
OBS: Note que em momento algum foi necessário simular, através da barra de 
simulação. 
 
Analise Dinâmica – Uso do Osciloscópio 
 
Posicionaremos agora, um osciloscópio para execução da análise em tempo real 
(utilização das chaves).  
 
Selecione o osciloscópio na opção “Virtual Instruments”. Posicione-o como  qualquer 
outro componente: 
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Figura 88: Inserção do Osciloscópio. 

 
 
Agora é iniciar a simulação. Note que a janela do osciloscópio virtual abre como um 
POP-UP. Caso você o feche (ou ele simplesmente não abra) navegue até: 
 
Debug > Digital Osciloscope 
 
Este caminho “Debug” monitora toda a informação que aparece em forma de janela 
avulsa dentro do Proteus. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 89: Caminho para a janela do osciloscópio. 
 
Agora, reposicione a janela do osciloscópio de forma que consiga enxergar o circuito 
atrás. Você pode alterar o estado das chaves enquanto simula, e observar a alteração 
do sinal na janela do osciloscópio. 
 
 
 
 
 
 
 
 
 
 
 
 



 

  94

PROTEUS 

 

ANACOM ELETRÔNICA LTDA 
Fone/Fax: (11) 3422-4200 

 www.anacom.com.br 
 

 
Figura 90: Janela no momento da simulação. 

� Exercício 3 - Criando um Esquemático com Microcontroladores. 
 

 
 
Primeiramente elabore o circuito acima, com os seguintes componentes. 
 
- PIC16F84A 
- AVX0805NP033P (Capacitor) 
- CRYSTAL 
- MINRES120K 
- LM016L 
- LED-GREEN 
 
Após o esquema ter sido elaborado, está na hora de criar o código fonte deste 
exercício para podermos visualizar sua simulação. 
 
No menu “Source” clique em “Add/Remove Source File” 
  
 
 
 
 
 
 
 
 

Figura 91: Caminho para inserção do código fonte. 
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Na janela “Add / Remove Source File”, você encontra informações sobre: 

- Target Processor: Informe 
qual microcontrolador você irá 
utilizar com determinado 
código fonte. 
 
- Code Generation Tool*: 
Informe qual será o tipo de 
compilador que irá utilizar 
para gerar o arquivo 
hexadecimal deste código 
fonte. 
 
- Source Code Filename**: 
Defina o seu código fonte.  

Figura 92: “Add/Remove Source Code”. 
 
Observação:  
 
** No Proteus somente o código *.ASM é aceito para compilação dos códigos. Podendo 
anexar outro tipo de programa ao Proteus para a compilação em C. 
 
*ASEM 51: Utilizado para famílias do 80C51 até 80C654 
 
*ASM11: Utilizado para famílias do 80C31 até 80C453 
 
*AVRASM2: Utilizado para família do microcontrolador AVR 
 
*MPASM: Utilizado para famílias de PIC10 até PIC16. 
 
*MPASMWIN: Utilizado para famílias de PIC18 e PIC 24 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Para a criação de um novo código fonte:
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Clique em NEW, crie um novo código inserindo  “nome.asm” clique em abrir. 

 
Aparecerá que não existe o arquivo “nome.asm” e se você deseja criá-lo, clique em sim 
para prosseguir. 
 
 
 
 
 
 
 
 
Vá ao menu “Source” e clique em “nome do código.asm”, com isso irá abrir o editor de 
texto para você escrever as linhas de comando para execução do seu esquemático. 

  
 
 
 
 
 
Após transcrever o código, clique em “Build All” para efetuar a compilação do código e 
anexar automaticamente o arquivo hexadecimal no microcontrolador que foi 
selecionado anteriormente. 
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No caso deste exercício, o código.ASM esta dentro do CD entregue juntamente com o 
material do treinamento. 
 
Selecione o código, e execute “Build all”. 
 
 
 

� Exercício 4 – Barramento 
 
Neste exercício, apresentaremos técnicas de endereçamento de barramentos e 
conexões rápidas via terminais. 
 
 
Esquemático: 

 
 
Lista de Materiais: 
 
-74LS373 
-CAP 
-8051.BUS 
-CRYSTAL 
-LM032L 
-NAND_2 
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Método de endereçamento do Barramento: 
 
 
 
 
 
 
 
 
 
 
 
 
 
1 – Selecione a opção Barramento: “Buses Mode” 
 
2 – Com “Buses Mode” desenhe o barramento desejado na saída do microcontrolador 
ou no ambiente de trabalho. 
 
3 – Clique com o botão direito do mouse sobre o barramento e acesse a opção “Place 
Wire Label” 
 
 
 
 
 
 
 
 
 

Figura 93: Caminho para “Place Wire Label”. 
 

4 – Daremos agora a informação referente a quantidade de informação que este 
barramento irá transportar. 
 
O barramento deverá ter o seguinte formato de string: 
 
<Nome>[nº do 1º Bit .. nº do ultimo Bit] 
 
Ex: Barramento de dados com 8 bits de informação: 
 
“D[0..7]” 
 
 
 
 
 

Figura 94:  Endereçamento. 
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Nomeado, o barramento terá o seguinte aspecto: 
 
 
 
 
 
 
 
5 – Após conectar um periférico a este barramento, clique com o botão direito sobre o 
fio de ligação do componente e selecione novamente a opção “Place Wire Label”. 
 
Note que, haverá uma lista com os endereços do barramento previamente inseridos. 
Selecione o endereço desejado e pressione OK. 

 
Endereços do Exercício Proposto: 

 
 
 
 
 
 
 
 
 
 
 

 
Código fonte fornecido no CD do Treinamento. 
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� Exercício 5 – Comunicação Serial Via RS232 
 
Neste exercício executaremos uma comunicação virtual entre nosso hardware e o 
teclado do computador, utilizando como elemento de sincronismo um software de 
emulação de portas de comunicação e o Hyperterminal do Windows. 
 
 
 
Esquemático do Hardware: 
 

 
 
Lista de Materiais 
 
-02013A330JAT2A 
-COMPIM 
-CRYSTAL 
-LED-GREEN 
-PIC16F628A 
-RES 
 
 
 
Código Fonte Fornecido no CD. 
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Guia do Código Fonte Utilizado: 
 
 
#include <16F628A.h> 
 
#FUSES XT 
#FUSES PUT 
#FUSES BROWNOUT 
#FUSES MCLR 
 
#use delay(clock=4M) 
#use rs232(baud=9600,parity=N,xmit=PIN_B2,rcv=PIN_B1, bits=8) 
 
#use fast_io(a) 
#byte porta=0x05 
#bit led=porta.0 
 
void main() 
{ 
 set_tris_a(0x00); 
 printf("Aperte qualquer tecla para mudar o estado do LED."); 
 led=1; 
 
 while(true) 
 { 
  if(kbhit()) 
  { 
   getc(); 
   led=!led; 
  } 
 } 
} 
 

 
 

• CONFIGURAÇÃO DA COMUNICAÇÃO SERIAL 
 

1 - A Primeira configuração a ser feita vem de um software que utilizaremos para 
simular nossas portas de comunicação virtualmente. 
 
O Software Utilizado será o VSPE, software emulador gratuito.  
 
2 - Execute o ícone do VSPE que se encontra na área de trabalho. 
 
 
 
 
 



 

  102

PROTEUS 

 

ANACOM ELETRÔNICA LTDA 
Fone/Fax: (11) 3422-4200 

 www.anacom.com.br 
 

A seguinte Janela deverá se abrir: 

Figura 95: Ambiente do VSPE. 
 

3 - Clique no Ícone abaixo para abrir a janela de configuração da porta serial virtual: 
 
 
 
 
 

4 - Configure na janela abaixo, através de “Device Type”, uma comunicação tipo Ponto 
a ponto (Pair), clique em avançar. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 96: Configuração do tipo de dispositivo: Pair. 
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5 - Defina as “pontas” da comunicação a ser realizada através do menu abaixo. 
 No caso deste exercício, defina como porta COM3 e COM4. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 97: Definição das portas. 
 
6 - Clique em concluir. A informação de status deverá aparecer como “Ready” na tela 
principal. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 98: Status: Ready. 
 
7 - Agora, a próxima configuração é feita na porta COMPIM. 
 
Volte ao Ambiente do Proteus. 
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8 - Um duplo clique no elemento COMPIM irá abrir a seguinte janela de configuração 
onde iremos configurar o nome da porta física, a taxa de transmissão física e virtual 
para o sincronismo da configuração. 
 
 
As seguintes configurações deverão ser aplicadas: 
 
Physical Port: COM3 (uma extremidade da comunicação 
emulada) 
Physical Baud Rate: 9600 
Physical Data Bits: 8 
Physical Parity: None 
Virtual Baud Rate: 9600 (mesma taxa de transmissão da 
Física) 
Virtual Data Bits: 8 
Virtual Parity: None 
 
(Informações coincidentes de “Physical” Para “Virtual”). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 99: Configurações de comunicação da porta COMPIM 
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A ultima configuração a ser feita é a do Hyperterminal do Windows. 
9 - Execute o HyperTerminal através do Ícone na área de trabalho: 
 
 
 
 
 
 
 
Caso ele exija, insira as configurações de região no Hyperterminal. 
A seguinte janela deverá se abrir após isto: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 100: Ambiente de trabalho do HyperTerminal. 
 
10 - Insira o nome da conexão. Para este exemplo, coloque o nome da segunda 
“extremidade” da conexão: C4 (Abreviação de COM4). 
 
11 - A próxima janela irá perguntar qual a porta de comunicação a ser utilizada. 
Selecione COM4. Clique em OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figura 101: Seleção do dispositivo que realizará a comunicação. 
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12 - A ultima configuração se refere a comunicação da porta COM4. Sincronize com as 
informações inseridas na porta COMPIM, com o detalhe que o campo CONTROLE DE 
FLUXO deve ser NENHUM. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 102: Configurações de comunicação de COM4 – Hyperterminal. 
 
 
 
13 - Pressione OK. 
 
14 - Retorne ao ambiente do Proteus e insira o código em Hexadecimal dentro do 
Microcontrolador. 
 
15 – Inicie a Simulação. Abra em paralelo o ambiente do Hyperterminal. Note que a 
frase contida no código do microcontrolador apareceu no ambiente:  
 
 
 
 
 
 
 
 
 
 
 
16 – Ainda no ambiente do Hyperterminal, aperte qualquer tecla.  
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Note que no ambiente do Proteus, o LED altera seu estado. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 103: Circuito Simulado. 
 
 

� Exercício 6 – Interface com o MPLAB IDE 
 
Neste Exercício realizaremos um projeto no MPLAB tendo como ferramenta de análise 
o Proteus, dentro do IDE. 
 
1 - O primeiro passo para isto é a criação do hardware a ser analisado antes de ir para 
o MPLAB. 
 
Esquematize o Hardware da pagina seguinte com os seguintes componente: 
 
-CRYSTAL 
 
-LED-BLUE 
 
-MINRES10K 
 
-MINRES330R 
 
-MONORES100P 
 
-PIC16F84A 
 
Código fonte fornecido no CD. 
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Hardware: 

Figura 104: Exercício Proposto. 
 
 
2 – Salve o Projeto e Feche o Proteus. 
 
3 – Abra o MPLAB. 
 
4 – Acesse a Opção “Project Wizard”. 
 
 
 
 
 
 
 
 

Figura 105: Caminho para Project Wizard... 
 
5 – Avance a janela de boas vindas, e selecione já próxima janela o microcontrolador 
utilizado neste exemplo. 
 
Digite PIC16F84A. 
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Figura 105: Definição do dispositivo. 
 
6 – Clique em Avançar. 
 
7 – Em “Active Toolsuite”, selecione a ferramenta que irá realizar a compilação deste 
projeto. Neste caso, selecione as Ferramentas da Hi-tech. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 106: Definição do Compilador. 
 
8 – Clique em Avançar. 
 
9 – A próxima opção pede o diretório onde todos os arquivos gerados pelo MPLAB 
serão salvos. Clique em BROWSE, crie uma pasta com nome MPLAB-LED, abra-a e 
dentro desta pasta, Nomeie o arquivo como EX_MPLAB. 
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Figura 107: Caminho do Exercício. 
 
10 – Avance e conclua o processo de criação do ambiente de programação sem inserir 
o código. 
 
11 - Vá até a arvore de projeto, na pasta “Source Files”, clique com o botão direito 
sobre esta opção e clique em “ADD FILES...”. Selecione o código fonte. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 108: Arvore de Projeto. 
 
 
12 – Com o código fonte Selecionado, de um duplo clique em seu arquivo, localizado 
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na Arvore de Projeto. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 109: Código fonte já dentro do MPLAB. 
 
 
13 – Vá até o menu “Debbugger > Select Tool > 1. Proteus VSM” . 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 110: Caminho para o Proteus VSM dentro do MPLAB. 
 
 
Selecionada esta Opção, um ambiente do Proteus deverá se abrir. 



 

  112

PROTEUS 

 

ANACOM ELETRÔNICA LTDA 
Fone/Fax: (11) 3422-4200 

 www.anacom.com.br 
 

Figura 111: Ambiente Proteus dentro do MPLAB. 
 
14 – Abra neste ambiente, o esquemático criado previamente. 
 
15 – com o esquemático aberto, clique no botão para compilar o código fonte. 
 
 
 
 
A seguinte janela deverá aparecer: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 112: Status da Compilação do código fonte. 
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16 – Note que um botão para simulação apareceu na área de trabalho.  
 
 
 
 
 
 
Estes botões referem-se a simulação do Proteus dentro do MPLAB. 
Não é necessário inserir o código hexadecimal dentro do microcontrolador, a partir do 
momento que o usuário clica em “Build”, o MPLAB envia uma cópia do Arquivo.hex 
para dentro do dispositivo. 
 
Clique no circulo verde. 
 
17 – A simulação do software Proteus foi habilitada, para iniciar, clique nas opções que 
agora estão disponíveis: 
 
 
 
 
 
Clique em “RUN” e observe o funcionamento na janela do Proteus. 
 
  

Figura 113: Exercício proposto dentro do MPLAB. 
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� Exercício 7 - Criação de alguns PCB’s a partir dos esquemáticos do ISIS. 
 
Roteamento manual 1. 
Esquemático: 

Figura 114: Exercício Proposto. 
 
Lista de Materiais: 
 
-555 
-CERAMIC330P 
-CONN-H2 
-LED-RED 
-METALFILM39K 
-MINERES68K 
 
 
 
OBS: para simulação deste exercício, é necessário entrar nas propriedades do 
conector e excluí-lo da simulação VSM, por não conter modelo SPICE associado. 
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1 – Note que os LED’s não possuem package associado. Assim sendo, se enviarmos a 
netlist para o ARES, um erro será ocasionado. 
 
Para resolver isto, clique com o botão direito sobre o LED e selecione a opção 
“Packaging Tool”. A janela de associação de Package utilizada para criação de 
componentes irá se abrir. 
 
2 clique em “ADD”. 
 
 
 
 
 

Figura 115: configuração do Package. 
 
3 – A biblioteca do Ares irá se abrir, selecione o encapsulamento para o LED e clique 
em OK. 
 
 
 
 
 
 
 
 

Figura 116: Seleção do Package. 
 
4 – Após clicar OK, o encapsulamento irá aparecer para definição de cada fio. Defina 
os extremos do LED e clique em Assign Package. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 117: Assimilação do Package. 
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5 – Note que agora os nomes A e K aparecem nos fios de conexão do LED. 
 
 
 
 
 
 
 

Figura 118: LED com Package associado. 
 
6 – Faça o mesmo procedimento para o outro LED e para cada componente que não 
possuir encapsulamento associado. 
 
7 – Clique no botão “Netlist to Ares” para enviar uma lista de materiais e conexões ao 
Ares. 
 
8 – Caso algum erro de falta de encapsulamento ou encapsulamento não encontrado 
ocorra, uma janela irá se abrir no ares. No caso de resistores, preencha o campo 
substituindo RES80 por RES40. 
 
Repita este processo para todos os componentes solicitados. 
 

 
 
 
 
 
 
 
 
 
 
 
 

 
9 – Após definir todos os encapsulamentos, eles estarão listados em “Device Mode”. 
 
Desenhando a Placa 
 
10 – Para desenhar a placa, utilize a ferramenta de desenho “2D Graphics Box Mode”, 
com a opção “Board Edge” Slecionada.  
 
 
 
 
 
 



 

  117

PROTEUS 

 

ANACOM ELETRÔNICA LTDA 
Fone/Fax: (11) 3422-4200 

 www.anacom.com.br 
 

 
11 – Utilizando a Origem como referência (ou utilizando o comando “O” para alterar a 
origem”, desenhe uma placa de 48,5mm por 32,5mm. 
 

Figura 119: Criação da borda da placa. 
A borda DEVE ficar em amarelo. 
 
12 – vá até “Component Mode”, selecione um componente e posicione na área de 
dentro da placa. 
 
Repita o processo e observe as linhas que apareceram. As Linhas amarelas não são 
tão importantes quando o posicionamento é manual, mas as verdes dizem onde cada 
ilha deve ser conectada através de uma trilha. 
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13 – Utilize a opção “Track Mode”  para conectar os 2 pontos indicados pelo 
“Ratsnest” (linha verde). 
 
  
 
 
 
 
 
 
 
 
 
 
 
 

Figura 120: Via Pronta. 
 
14 – Posicione todos os componentes e repita o processo anterior, realizando o 
roteamento manual do circuito proposto. 
 

  
Figura 121: Placa roteada. 
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15 – Visualização 3D 
 
A Visualização 3D pode ser acessada através do caminho: 
 
Output> 3D Visualization  
 
 
Vista Superior: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Vista Inferior: 
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� Exercício 8 – Roteamento Manual 2 – Planos de energia. 
 
 
 
Esquemático: 
 

Figura 122: Exercício Proposto. 
 
 
Lista de Materiais: 
 
- 555 
 
- 52207-0319 
 
- CERAMIC470P 
 
- DIODE 
 
- IRFZ46N 
 
- MOTOR  
 
- POT-HG 
 
 
1 – Esquematize o circuito. 
 
2 – No momento da simulação, o Potênciometro DEVE começar em no valor “Zero”. 
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3 – Clique com o botão direito sobre os terminais de força, e selecione na lista 
existente GND para as trilhas de terra e VCC para as trilhas de 5V. 
 
4 – Para as trilhas de 9V, digite “9V” no campo “String”. 
 
Após isto vá até o caminho: 
 

• Design > Configure Power Rails... 
 
 
 
 
 
 
 
 

Figura 123: Caminho para configuração dos Power Nets. 
A seguinte janela deverá se abrir. Note que o “9V” que você digitou deverá estar listado 
como um plano “não conectado”. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
5 – Clique em “New”, e crie uma fonte de 9V. De o Nome de 9V. Note que a voltagem 
será ajustada para 9V automaticamente. Agora selecione os 9V em “Unconnected 
power nets” e clique em “add”. Desta forma você estará associando o valor de 9V de 
tensão com a string do símbolo do terminal “Power”, criado por você no esquemático. 
 
 
 
 
 
 
 

Figura 124: Configuração do nível de tensão no Power net, e assimilação com a String. 
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- Pressione OK. 
 
6 – Associe um package a todos os componentes que não possuem Footprint PCB. 
 
7 – Envie o Netlist ao Ares. 
 
8 – Desenhe a borda da placa com 55mmx55mm. 
 
9 – Posicione os componentes. 
 
10 – Selecione a opção “Zone Mode”    
 
Observe que o cursor do mouse se tornou um lápis. 
Posicione-o no extremo da placa, e arraste até completar um quadrado que alcance 
toda a área da placa. Ao terminar de desenhar, esta janela irá aparecer: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 125: Configuração dos Power Planes. 
 
Informe que o NET de GND ira se localizar no BOTTOM da placa com uma expessura 
de 8 mills. Clique em OK. 
 
- 11 crie um plano de VCC em TOP e um plano de 9V no Layer 1 (Inner 1). Note que 
parte das conexões (ratsnets) irão desaparecer. 
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12 - Efetue o Roteamento com a ferramenta “Track mode” para as vias restantes.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 126: Placa com planos de VCC, GND e 9V. 
 
13 - Gere a visualização 3D da placa. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figura 127: Visualização final da Placa Pronta. 


